Skip to main content
Public proof of conceptFix available

CVE-2022-1565

A public proof of concept exists; no exploitation attested.

  • Published2022-07-18
  • Fixed in3.6.8
  • WeaknessCWE-434

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The plugin WP All Import is vulnerable to arbitrary file uploads due to missing file type validation via the wp_all_import_get_gz.php file in versions up to, and including, 3.6.7. This makes it possible for authenticated attackers, with administrator level permissions and above, to upload arbitrary files on the affected sites server which may make remote code execution possible.

Timeline

dates in UTC
  1. 2022-07-1817:15CVE publishedNVD
  2. 2023-03-29Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-1565?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-1565?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Wpallimport wp all import
BranchAffectedFixed in
3.6< 3.6.83.6.8

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As Wordfence, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • wpallimport Import any XML or CSV File to WordPressother versions: not affected
    Affected
    • ≤ 3.6.7no fix statedsemver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-10-20

Fix

  1. Update Wpallimport wp all import to 3.6.8

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-51122
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedphanthibichtram12/CVE-2022-1565
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Published
2022-07-18
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-ggqc-76h3-jpv2

Frequently asked questions

What is CVE-2022-1565?

The plugin WP All Import is vulnerable to arbitrary file uploads due to missing file type validation via the wp_all_import_get_gz.php file in versions up to, and including, 3.6.7. This makes it possible for authenticated attackers, with administrator level permissions and above, to upload arbitrary files on the affected sites server which may make remote code execution possible.

Is CVE-2022-1565 actively exploited?

Active exploitation of CVE-2022-1565 has not been confirmed. Its EPSS score was 15.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2022-1565?

CVE-2022-1565 has a CVSS v3 base score of 7.2 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record