Skip to main content
ExploitedIn CISA KEVFix available

CVE-2022-33891

Exploitation confirmed. First attested on 2023-03-07 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2022-07-18
  • Fixed in3.2.2 · 3.1.3 · 3.0.4
  • WeaknessCWE-78

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1.

Timeline

dates in UTC
  1. 2022-07-1807:15CVE publishedNVD
  2. 2023-03-07Added to the CISA KEV catalogCISA KEV
  3. 2023-03-07Listed as exploited by GCVEGCVE
  4. 2023-03-07Exploitation first reportedCISA KEV
  5. 2025-02-0414:13SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-33891?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-33891?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
spark
BranchAffectedFixed in
3.2≥ 3.2.0, < 3.2.23.2.2
3.1≥ 3.1.1, < 3.1.33.1.3
3.0< 3.0.43.0.4
Apache spark
BranchAffectedFixed in
3.0≤ 3.0.3no fix published
3.1≥ 3.1.1, ≤ 3.1.2no fix published
3.2≥ 3.2.0, ≤ 3.2.1no fix published
pyspark
BranchAffectedFixed in
3.2≥ 3.2.0, < 3.2.23.2.2
3.1< 3.1.33.1.3

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As apache, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Apache Software Foundation Apache Spark
    Affected
    • ≥ 3.0.3 and earlier, ≤ 3.0.3no fix statedcustom
    • ≥ 3.1.1 to 3.1.2, ≤ 3.1.2no fix statedcustom
    • ≥ 3.2.0 to 3.2.1, ≤ 3.2.1no fix statedcustom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-07-25

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • openstack-barbicanSUSE:OpenStack Cloud Crowbar 9all versions · fixed in 7.0.1~dev24-3.17.1
  • openstack-barbicanSUSE:OpenStack Cloud 9all versions · fixed in 7.0.1~dev24-3.17.1
  • openstack-heat-gbpSUSE:OpenStack Cloud Crowbar 9all versions · fixed in 14.0.1~dev5-3.12.1
  • openstack-heat-gbpSUSE:OpenStack Cloud 9all versions · fixed in 14.0.1~dev5-3.12.1
  • openstack-horizon-plugin-gbp-uiSUSE:OpenStack Cloud Crowbar 9all versions · fixed in 14.0.1~dev6-3.15.1
  • openstack-horizon-plugin-gbp-uiSUSE:OpenStack Cloud 9all versions · fixed in 14.0.1~dev6-3.15.1
  • openstack-neutronSUSE:OpenStack Cloud Crowbar 9all versions · fixed in 13.0.8~dev209-3.43.1
  • openstack-neutronSUSE:OpenStack Cloud 9all versions · fixed in 13.0.8~dev209-3.43.1

8 more package ranges on OSV.dev

Vendor advisories

  • CVE-2022-33891 Red Hat Product Security

    apache-spark: Apache Spark shell command injection vulnerability via Spark UI

Full record on NVD

Fix

  1. Update spark to 3.2.2 · 3.1.3 · 3.0.4
  2. CISA’s required action: Apply updates per vendor instructions.due 2023-03-28

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/linux/http/apache_spark_rce_cve_2022_33891rank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2023-03-07
Patch Due Date
2023-03-28
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2022-07-18
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-4x9r-j582-cgr8

Frequently asked questions

What is CVE-2022-33891?

The Apache Spark UI offers the possibility to enable ACLs via the configuration option spark.acls.enable. With an authentication filter, this checks whether a user has access permissions to view or modify the application. If ACLs are enabled, a code path in HttpSecurityFilter can allow someone to perform impersonation by providing an arbitrary user name. A malicious user might then be able to reach a permission check function that will ultimately build a Unix shell command based on their input, and execute it. This will result in arbitrary shell command execution as the user Spark is currently running as. This affects Apache Spark versions 3.0.3 and earlier, versions 3.1.1 to 3.1.2, and versions 3.2.0 to 3.2.1.

Is CVE-2022-33891 actively exploited?

Yes. CVE-2022-33891 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2023-03-28.

What is the CVSS score for CVE-2022-33891?

CVE-2022-33891 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running spark? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record