Skip to main content
Public proof of conceptFix available

CVE-2022-1442

A public proof of concept exists; no exploitation attested.

  • Published2022-05-10
  • Fixed in2.1.4
  • WeaknessCWE-862

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Metform WordPress plugin is vulnerable to sensitive information disclosure due to improper access control in the ~/core/forms/action.php file which can be exploited by an unauthenticated attacker to view all API keys and secrets of integrated third-party APIs like that of PayPal, Stripe, Mailchimp, Hubspot, HelpScout, reCAPTCHA and many more, in versions up to and including 2.1.3.

Timeline

dates in UTC
  1. 2022-05-1020:15CVE publishedNVD

Versions per branch

NVD
Wpmet metform elementor contact form builder
BranchAffectedFixed in
2.1< 2.1.42.1.4

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As Wordfence, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementorother versions: not affected
    Affected
    • ≤ 2.1.3no fix statedsemver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-04-08

Fix

  1. Update Wpmet metform elementor contact form builder to 2.1.4

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2022-05-10
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-mxm7-jfgp-4j4v

Frequently asked questions

What is CVE-2022-1442?

The Metform WordPress plugin is vulnerable to sensitive information disclosure due to improper access control in the ~/core/forms/action.php file which can be exploited by an unauthenticated attacker to view all API keys and secrets of integrated third-party APIs like that of PayPal, Stripe, Mailchimp, Hubspot, HelpScout, reCAPTCHA and many more, in versions up to and including 2.1.3.

Is CVE-2022-1442 actively exploited?

A proof-of-concept exploit exists for CVE-2022-1442, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-1442?

CVE-2022-1442 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record