CVE-2022-29885
A public proof of concept exists; no exploitation attested.
- Published2022-05-12
- WeaknessCWE-400
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
The documentation of Apache Tomcat 10.1.0-M1 to 10.1.0-M14, 10.0.0-M1 to 10.0.20, 9.0.13 to 9.0.62 and 8.5.38 to 8.5.78 for the EncryptInterceptor incorrectly stated it enabled Tomcat clustering to run over an untrusted network. This was not correct. While the EncryptInterceptor does provide confidentiality and integrity protection, it does not protect against all risks associated with running over any untrusted network, particularly DoS risks.
Timeline
dates in UTC- 2022-05-1208:15CVE publishedNVD
- 2023-04-05Exploit-DB entryExploit-DB
Observed activity
isMalicious corpus · updated 2026-11-04 09:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-29885?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-29885?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 8.5 | ≥ 8.5.38, ≤ 8.5.78 | no fix published | NVD |
| 9.0 | ≥ 9.0.13, ≤ 9.0.62 | no fix published | NVD |
| 10.0 | ≥ 10.0.0, ≤ 10.0.20 | no fix published | NVD |
| 10.1 | = 10.1.0 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 10.1 | ≥ 10.1.0-M1, < 10.1.0-M15 | 10.1.0-M15 | OSV |
| 10.0 | ≥ 10.0.0-M1, < 10.0.21 | 10.0.21 | OSV |
| 9.0 | ≥ 9.0.13, < 9.0.63 | 9.0.63 | OSV |
| 8.5 | ≥ 8.5.38, < 8.5.79 | 8.5.79 | OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 10.0 | ≥ 10.0.0, < 10.0.21 | 10.0.21 | OSV |
| 9.0 | ≥ 9.0.13, < 9.0.63 | 9.0.63 | OSV |
| 8.5 | ≥ 8.5.38, < 8.5.79 | 8.5.79 | OSV |
2 more products in the sources.
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- org.apache.tomcat:tomcatTuxCare:Mavenfrom 8.5.46 · fixed in 8.5.46-tuxcare.1and 6 other packages
- org.apache.tomcat:tomcatTuxCare:Mavenfrom 9.0.24 · fixed in 9.0.24-tuxcare.1and 7 other packages
- org.apache.tomcat:tomcatTuxCare:Mavenfrom 9.0.39 · fixed in 9.0.39-tuxcare.2and 4 other packages
- org.apache.tomcat:tomcatTuxCare:Mavenfrom 9.0.46 · fixed in 9.0.46-tuxcare.1and 4 other packages
- org.apache.tomcat:tomcatTuxCare:Mavenfrom 9.0.50 · fixed in 9.0.50-tuxcare.11and 3 other packages
- org.apache.tomcat:tomcatTuxCare:Mavenfrom 8.5.78 · fixed in 8.5.78-tuxcare.1and 6 other packages
- tomcatTuxCare:AlmaLinux:9.2all versions · fixed in 1:9.0.62-11.el9.3.tuxcare.els18and 7 other packages
- tomcatMageia:8all versions · fixed in 9.0.73-1.1.mga8
14 more package ranges on OSV.dev
Vendor advisories
tomcat: EncryptInterceptor documentation mistake
tomcat as a component of Red Hat Decision Manager 7 · tomcat6 as a component of Red Hat Enterprise Linux 6 · tomcat6-admin-webapps as a component of Red Hat Enterprise Linux 6 · +38 more
Fix
- Workaround from the vendor Red Hat Product Security CVE-2022-29885 · 41 productsFor customers who use clustering on an untrusted network and require full protection, an alternate solution is recommended such as using a VPN.
- No fix planned, says the vendor Red Hat Product Security CVE-2022-29885 · 41 productsWill not fix
Advisories and patches
- lists.apache.orgMitigation · Vendor Advisory
- www.oracle.comPatch
Detection
read 2026-11-03 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Proof-of-concept repositories
- 2 repositories, unverifiedquynhlab/CVE-2022-29885iveresk/CVE-2022-29885 PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionnone2026-10-08
- OpenCVESSVC decisionnone—
- NVDCVSS 3.17.5read 2026-10-23
- NVDCVSS 2.05read 2026-10-23
- CNAweakness (CWE)CWE-400known since 2026-10-23
- FIRST EPSSEPSS score73.5 %read 2026-11-03
- PoC-in-GitHubproof of concept2read 2026-11-03
- Exploit-DBdetectionread 2026-11-03
- OSVaffected packages—
- GitHub AdvisoriesadvisoryHIGH2024-03-11
Identifiers
- BIT-tomcat-2022-29885same flawBitnami · Apache-2.0
- EUVD-2022-5128same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-r84p-88g2-2vx2same flawGitHub Advisory Database · CC-BY-4.0
- DLA-3160-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-5265-1advisory covering several CVEsDebian · LicenseRef-unstated
- MGASA-2023-0138advisory covering several CVEsMageia · LicenseRef-unstated
- USN-6943-1advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Published
- 2022-05-12
- Last Modified
- 2026-10-08
- NVD status
- Modified
- GitHub Advisory
- GHSA-r84p-88g2-2vx2
Frequently asked questions
What is CVE-2022-29885?
Is CVE-2022-29885 actively exploited?
What is the CVSS score for CVE-2022-29885?
Running Apache Tomcat? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-r84p-88g2-2vx2
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- PoC-in-GitHub · CC0-1.0
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0
- CISA Vulnrichment · CC0-1.0