Skip to main content
No exploitation reportedFix available

CVE-2021-44223

No exploitation reported by the sources we read.

  • Published2021-11-25
  • Fixed in5.8

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.

Timeline

dates in UTC
  1. 2021-11-2515:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-44223?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-44223?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
WordPress
BranchAffectedFixed in
5.8< 5.85.8
wordpress
BranchAffectedFixed in
5.8< 5.8.05.8.0
wordpress-multisite
BranchAffectedFixed in
5.8< 5.8.05.8.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • wordpressUbuntu:20.04:LTSall versions · no fixed version listed
  • wordpressUbuntu:18.04:LTSall versions · no fixed version listed
  • wordpressUbuntu:16.04:LTSall versions · no fixed version listed
  • wordpressDebian:14all versions · fixed in 5.8.1+dfsg1-1
  • wordpressDebian:13all versions · fixed in 5.8.1+dfsg1-1
  • wordpressDebian:12all versions · fixed in 5.8.1+dfsg1-1

Vendor advisories

  • CVE-2021-44223 Red Hat Product Security

    wordpress: remote code execution via a supply-chain attack

Full record on NVD

Fix

  1. Update WordPress to 5.8

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 3.18.1known since 2026-10-23
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • FIRST EPSSEPSS score29.0 %read 2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2021-11-25
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-44223?

WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.

Is CVE-2021-44223 actively exploited?

Active exploitation of CVE-2021-44223 has not been confirmed. Its EPSS score was 29.0% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-44223?

CVE-2021-44223 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running WordPress? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record