Skip to main content
Exploitation reportedNot in CISA KEV yetFix available

CVE-2019-8942

Exploitation reported by one source. First attested on 2026-07-30 by GCVE · kevintel.

  • Published2019-02-20
  • Fixed in4.9.9
  • WeaknessCWE-434

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Timeline

dates in UTC
  1. 2019-02-2003:29CVE publishedNVD
  2. 2019-03-01Exploit-DB entryExploit-DB
  3. 2026-07-3010:42Listed as exploited by GCVEGCVE
  4. 2026-07-3010:42Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-8942?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-8942?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
WordPress
BranchAffectedFixed in
4.9< 4.9.94.9.9
5.0= 5.0no fix published
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • wordpressUbuntu:18.04:LTSall versions · no fixed version listed
  • wordpressUbuntu:16.04:LTSall versions · no fixed version listed
  • wordpressDebian:14all versions · fixed in 5.0.1+dfsg1-1
  • wordpressDebian:13all versions · fixed in 5.0.1+dfsg1-1
  • wordpressDebian:12all versions · fixed in 5.0.1+dfsg1-1
  • wordpressDebian:9all versions · fixed in 4.7.5+dfsg-2+deb9u5
  • wordpressDebian:8all versions · fixed in 4.1.26+dfsg-1+deb8u1

Vendor advisories

  • CVE-2019-8942 Red Hat Product Security

    wordpress: Author users can execute arbitrary code by leveraging path traversal

Full record on NVD

Fix

  1. Update WordPress to 4.9.9

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-46511EDB-46662
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/wp_crop_rcerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2019-02-20
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2019-8942?

WordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.

Is CVE-2019-8942 actively exploited?

Active exploitation of CVE-2019-8942 has not been confirmed. Its EPSS score was 82.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-8942?

CVE-2019-8942 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running WordPress? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record