Skip to main content
Public proof of conceptFix available

CVE-2020-8794

A public proof of concept exists; no exploitation attested.

  • Published2020-02-25
  • Fixed in6.6.4
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

OpenSMTPD before 6.6.4 allows remote code execution because of an out-of-bounds read in mta_io in mta_session.c for multi-line replies. Although this vulnerability affects the client side of OpenSMTPD, it is possible to attack a server because the server code launches the client code during bounce handling.

Timeline

dates in UTC
  1. 2020-02-26Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-8794?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-8794?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Opensmtpd
BranchAffectedFixed in
6.6< 6.6.46.6.4
Canonical ubuntu linux
BranchAffectedFixed in
18.4= 18.04no fix published
19.10= 19.10no fix published
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published
10.0= 10.0no fix published

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • opensmtpdUbuntu:Pro:16.04:LTSall versions · fixed in 5.7.3p2-1ubuntu0.1~esm2
  • opensmtpdUbuntu:Pro:14.04:LTSall versions · fixed in 5.4.1p1-1ubuntu0.1~esm1
  • opensmtpdUbuntu:20.04:LTSall versions · fixed in 6.6.4p1-1
  • opensmtpdUbuntu:18.04:LTSall versions · fixed in 6.0.3p1-1ubuntu0.2
  • opensmtpdDebian:14all versions · fixed in 6.6.4p1-1
  • opensmtpdDebian:13all versions · fixed in 6.6.4p1-1
  • opensmtpdDebian:12all versions · fixed in 6.6.4p1-1
  • opensmtpdDebian:10all versions · fixed in 6.0.3p1-5+deb10u4

10 more package ranges on OSV.dev

Vendor advisories

  • CVE-2020-8794 Red Hat Product Security

    opensmtpd: An out-of-bounds read could lead to remote code execution

Full record on NVD

Fix

  1. Update Opensmtpd to 6.6.4

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-48140EDB-48185
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/unix/local/opensmtpd_oob_read_lperank: averageModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2020-02-25
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2020-8794?

OpenSMTPD before 6.6.4 allows remote code execution because of an out-of-bounds read in mta_io in mta_session.c for multi-line replies. Although this vulnerability affects the client side of OpenSMTPD, it is possible to attack a server because the server code launches the client code during bounce handling.

Is CVE-2020-8794 actively exploited?

Active exploitation of CVE-2020-8794 has not been confirmed. Its EPSS score was 88.9% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-8794?

CVE-2020-8794 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running opensmtpd? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record