CVE-2020-2021
Exploitation confirmed. First attested on 2022-03-25 by CISA-ADP, CISA KEV, GCVE · kevintel.
- Published2020-06-29
- Fixed in9.1.3 · 9.0.9 · 8.1.15
- WeaknessCWE-347
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
When Security Assertion Markup Language (SAML) authentication is enabled and the 'Validate Identity Provider Certificate' option is disabled (unchecked), improper verification of signatures in PAN-OS SAML authentication enables an unauthenticated network-based attacker to access protected resources. The attacker must have network access to the vulnerable server to exploit this vulnerability. This issue affects PAN-OS 9.1 versions earlier than PAN-OS 9.1.3; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15, and all versions of PAN-OS 8.0 (EOL). This issue does not affect PAN-OS 7.1. This issue cannot be exploited if SAML is not used for authentication. This issue cannot be exploited if the 'Validate Identity Provider Certificate' option is enabled (checked) in the SAML Identity Provider Server Profile. Resources that can be protected by SAML-based single sign-on (SSO) authentication are: GlobalProtect Gateway, GlobalProtect Portal, GlobalProtect Clientless VPN, Authentication and Captive Portal, PAN-OS next-generation firewalls (PA-Series, VM-Series) and Panorama web interfaces, Prisma Access In the case of GlobalProtect Gateways, GlobalProtect Portal, Clientless VPN, Captive Portal, and Prisma Access, an unauthenticated attacker with network access to the affected servers can gain access to protected resources if allowed by configured authentication and Security policies. There is no impact on the integrity and availability of the gateway, portal or VPN server. An attacker cannot inspect or tamper with sessions of regular users. In the worst case, this is a critical severity vulnerability with a CVSS Base Score of 10.0 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N). In the case of PAN-OS and Panorama web interfaces, this issue allows an unauthenticated attacker with network access to the PAN-OS or Panorama web interfaces to log in as an administrator and perform administrative actions. In the worst-case scenario, this is a critical severity vulnerability with a CVSS Base Score of 10.0 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H). If the web interfaces are only accessible to a restricted management network, then the issue is lowered to a CVSS Base Score of 9.6 (CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H). Palo Alto Networks is not aware of any malicious attempts to exploit this vulnerability.
Timeline
dates in UTCObserved activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-2021?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-2021?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 9.1 | ≥ 9.1.0, < 9.1.3 | 9.1.3 | NVD |
| 9.0 | ≥ 9.0.0, < 9.0.9 | 9.0.9 | NVD |
| 8.1 | ≥ 8.1.0, < 8.1.15 | 8.1.15 | NVD |
| 8.0 | ≥ 8.0.0, ≤ 8.0.20 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As palo_alto, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Palo Alto Networks PAN-OSAffected
- = 8.0.*no fix stated
- ≥ 8.1, < 8.1.15fixed in 8.1.15custom
- ≥ 9.0, < 9.0.9fixed in 9.0.9custom
- ≥ 9.1, < 9.1.3fixed in 9.1.3custom
Not affected = 7.1.*
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2020-06-29
Fix
- Update Palo Alto PAN-OS to 9.1.3 · 9.0.9 · 8.1.15
- CISA’s required action: Apply updates per vendor instructions.due 2022-04-15
Advisories and patches
- security.paloaltonetworks.comMitigation · Vendor Advisory
Detection
read 2026-11-02 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- 1 repository, unverifiedmngunibanda1-prog/Jozini-network-scanner PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
CISA Known Exploited Vulnerability
- Date Added
- 2022-03-25
- Patch Due Date
- 2022-04-15
- Ransomware Use
- Known
- Required Action
- Apply updates per vendor instructions.
Sources
- CISA KEVKEV entry2022-03-25
- ENISA EUVDexploitation2022-03-252022-03-25
- GCVEexploitation2022-03-25
- CISA-ADPSSVC decisionactive2025-02-07
- OpenCVESSVC decisionactive—
- CNACVSS 3.110known since 2026-10-23
- NVDCVSS 3.110read 2026-10-23
- NVDCVSS 2.09.3read 2026-10-23
- CNAweakness (CWE)CWE-347known since 2026-10-23
- NVDweakness (CWE)CWE-347read 2026-10-23
- FIRST EPSSEPSS score4.4 %2026-11-03
- PoC-in-GitHubproof of concept1read 2026-11-02
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2020-22049same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-84wc-9427-hw23same flawGitHub Advisory Database · CC-BY-4.0
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Published
- 2020-06-29
- Last Modified
- 2026-06-17
- NVD status
- Analyzed
- GitHub Advisory
- GHSA-84wc-9427-hw23
Frequently asked questions
What is CVE-2020-2021?
Is CVE-2020-2021 actively exploited?
What is the CVSS score for CVE-2020-2021?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- For a threat intelligence platform: malware, C2 and ransomware indicators over STIX/TAXII.
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CISA KEV · CC0-1.0 (cisagov/kev-data)
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GCVE · GCVE dump terms (preserve source attribution)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-84wc-9427-hw23
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- PoC-in-GitHub · CC0-1.0
- CISA Vulnrichment · CC0-1.0