Skip to main content
No exploitation reportedFix available

CVE-2019-25043

No exploitation reported by the sources we read.

  • Published2021-05-06
  • Fixed in3.0.4
  • WeaknessCWE-755

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

ModSecurity 3.x before 3.0.4 mishandles key-value pair parsing, as demonstrated by a "string index out of range" error and worker-process crash for a "Cookie: =abc" header.

Timeline

dates in UTC
  1. 2021-05-0617:15CVE publishedNVD

Versions per branch

NVD
Owasp modsecurity
BranchAffectedFixed in
3.0≥ 3.0.0, < 3.0.43.0.4

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • modsecurityUbuntu:26.10all versions · no fixed version listed
  • modsecurityUbuntu:26.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:25.10all versions · no fixed version listed
  • modsecurityUbuntu:24.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:22.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:20.04:LTSall versions · no fixed version listed
  • modsecurityDebian:14all versions · fixed in 3.0.4-1
  • modsecurityDebian:13all versions · fixed in 3.0.4-1

1 more package range on OSV.dev

Vendor advisories

  • CVE-2019-25043 Red Hat Product Security

    libmodsecurity: crafted key-value pair can lead to DoS

Full record on NVD

Fix

  1. Update Owasp modsecurity to 3.0.4

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.15.3read 2026-10-23
  • NVDCVSS 2.05read 2026-10-23
  • NVDweakness (CWE)CWE-755read 2026-10-23
  • FIRST EPSSEPSS score1.2 %2026-11-05
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Published
2021-05-06
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2019-25043?

ModSecurity 3.x before 3.0.4 mishandles key-value pair parsing, as demonstrated by a "string index out of range" error and worker-process crash for a "Cookie: =abc" header.

Is CVE-2019-25043 actively exploited?

Active exploitation of CVE-2019-25043 has not been confirmed. Its EPSS score was 1.2% on 2026-11-05, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-25043?

CVE-2019-25043 has a CVSS v3 base score of 5.3 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L.

Running libmodsecurity? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record