Skip to main content
Public proof of conceptFix available

CVE-2026-52747

A public proof of concept exists; no exploitation attested.

  • Published2026-07-10
  • Fixed in3.0.16
  • WeaknessCWE-180

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 3.0.16, the multipart/form-data request body parser in libmodsecurity silently removes embedded line breaks from non-file form-field values before exporting them to ARGS and ARGS_POST because src/request_body_processor/multipart.cc overwrites reserved bytes in m_reserve instead of appending the current buffer. This creates a parser differential between ModSecurity and backend applications that preserve line breaks in form fields, allowing rules that inspect ARGS or ARGS_POST to miss payloads whose dangerous syntax depends on a line break. This issue is fixed in version 3.0.16.

Timeline

dates in UTC
  1. 2026-07-1022:16CVE publishedNVD

Versions per branch

NVD · OSV
Owasp modsecurity
BranchAffectedFixed in
3.0< 3.0.163.0.16

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • owasp-modsecurity ModSecurity
    Affected
    • = < 3.0.16no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-07-10

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • mod_securityAzure Linux:3all versions · no fixed version listed
  • modsecurityUbuntu:26.10all versions · no fixed version listed
  • modsecurityUbuntu:26.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:24.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:22.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:20.04:LTSall versions · no fixed version listed
  • modsecurityDebian:14all versions · fixed in 3.0.16-1
  • modsecurityDebian:13all versions · no fixed version listed

1 more package range on OSV.dev

Full record on NVD

Fix

  1. Update Owasp modsecurity to 3.0.16

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
Published
2026-07-10
Last Modified
2026-10-25
NVD status
Analyzed
GitHub Advisory
GHSA-rcw9-2f5r-7p88

Frequently asked questions

What is CVE-2026-52747?

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 3.0.16, the multipart/form-data request body parser in libmodsecurity silently removes embedded line breaks from non-file form-field values before exporting them to ARGS and ARGS_POST because src/request_body_processor/multipart.cc overwrites reserved bytes in m_reserve instead of appending the current buffer. This creates a parser differential between ModSecurity and backend applications that preserve line breaks in form fields, allowing rules that inspect ARGS or ARGS_POST to miss payloads whose dangerous syntax depends on a line break. This issue is fixed in version 3.0.16.

Is CVE-2026-52747 actively exploited?

A proof-of-concept exploit exists for CVE-2026-52747, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2026-52747?

CVE-2026-52747 has a CVSS v3 base score of 8.6 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N.

Running modsecurity? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record