Skip to main content
Public proof of conceptFix available

CVE-2026-30923

A public proof of concept exists; no exploitation attested.

  • Published2026-05-05
  • Fixed in3.0.15
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Libmodsecurity is one component of the ModSecurity v3 project. A segmentation fault occurs when a rule using the t:hexDecode transformation inspects a query string parameter containing a single character. An attacker can exploit this to crash worker processes, causing a denial of service. Service resumes once the attack stops as worker processes recover from the segfault. All versions before 3.0.15 of libModSecurity3 are affected. This has been patched in version 3.0.15.

Timeline

dates in UTC
  1. 2026-05-0519:16CVE publishedNVD

Versions per branch

NVD · OSV
Owasp modsecurity
BranchAffectedFixed in
3.0< 3.0.153.0.15
3.0≥ 3.0.0, < 3.0.153.0.15

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • owasp-modsecurity ModSecurity
    Affected
    • = < 3.0.15no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-05-05

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • mod_securityAzure Linux:3all versions · no fixed version listed
  • modsecurityUbuntu:26.10all versions · no fixed version listed
  • modsecurityUbuntu:26.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:25.10all versions · no fixed version listed
  • modsecurityUbuntu:24.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:22.04:LTSall versions · no fixed version listed
  • modsecurityUbuntu:20.04:LTSall versions · no fixed version listed
  • modsecurityopenSUSE:Tumbleweedall versions · fixed in 3.0.15-1.1

3 more package ranges on OSV.dev

Full record on NVD

Fix

  1. Update Owasp modsecurity to 3.0.15

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2026-05-05
Last Modified
2026-07-25
NVD status
Analyzed
GitHub Advisory
GHSA-qrjc-3jpc-3h2g

Frequently asked questions

What is CVE-2026-30923?

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Libmodsecurity is one component of the ModSecurity v3 project. A segmentation fault occurs when a rule using the t:hexDecode transformation inspects a query string parameter containing a single character. An attacker can exploit this to crash worker processes, causing a denial of service. Service resumes once the attack stops as worker processes recover from the segfault. All versions before 3.0.15 of libModSecurity3 are affected. This has been patched in version 3.0.15.

Is CVE-2026-30923 actively exploited?

A proof-of-concept exploit exists for CVE-2026-30923, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2026-30923?

CVE-2026-30923 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running modsecurity? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record