CVE-2019-2215
Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel.
- Published2019-10-11
- Fixed in9.1.0.246\(c432e6r1p7t8\) · 9.1.0.201\(c636e4r1p5t8\) · 9.1.0.201\(zafc185e4r1p8t8\) · 9.1.0.200\(c605e4r1p3t8\) · 9.1.0.200\(c635e5r1p1t8\) · 9.1.0.200\(c636e4r1p5t8\)
- WeaknessCWE-416
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
A use-after-free in binder.c allows an elevation of privilege from an application to the Linux Kernel. No user interaction is required to exploit this vulnerability, however exploitation does require either the installation of a malicious local application or a separate vulnerability in a network facing application.Product: AndroidAndroid ID: A-141720095
Timeline
dates in UTC- 2019-10-04Exploit-DB entryExploit-DB
- 2019-10-1119:15CVE publishedNVD
- 2021-11-03Added to the CISA KEV catalogCISA KEV
- 2021-11-03Listed as exploited by GCVEGCVE
- 2021-11-03Exploitation first reportedCISA KEV
- 2025-02-0713:04SSVC exploitation set to activeCISA-ADP
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-2215?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-2215?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 9.1 | < 9.1.0.246\(c432e6r1p7t8\) | 9.1.0.246\(c432e6r1p7t8\) | NVD |
| 9.1 | < 9.1.0.201\(c636e4r1p5t8\) | 9.1.0.201\(c636e4r1p5t8\) | NVD |
| 9.1 | < 9.1.0.201\(zafc185e4r1p8t8\) | 9.1.0.201\(zafc185e4r1p8t8\) | NVD |
| 9.1 | < 9.1.0.200\(c605e4r1p3t8\) | 9.1.0.200\(c605e4r1p3t8\) | NVD |
| 9.1 | < 9.1.0.200\(c635e5r1p1t8\) | 9.1.0.200\(c635e5r1p1t8\) | NVD |
| 9.1 | < 9.1.0.200\(c636e4r1p5t8\) | 9.1.0.200\(c636e4r1p5t8\) | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 9.1 | < 9.1.0.201\(c636e4r1p5t8\) | 9.1.0.201\(c636e4r1p5t8\) | NVD |
| 9.1 | < 9.1.0.201\(zafc185e4r1p8t8\) | 9.1.0.201\(zafc185e4r1p8t8\) | NVD |
| 9.1 | < 9.1.0.200\(c636e4r1p5t8\) | 9.1.0.200\(c636e4r1p5t8\) | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 16.4 | = 16.04 | no fix published | NVD |
74 more products in the sources.
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As google_android, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- AndroidAffected
- = Kernelno fix stated
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2020-03-02
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- linuxUbuntu:16.04:LTSall versions · fixed in 4.4.0-168.197
- linuxDebian:14all versions · fixed in 4.15.4-1
- linuxDebian:13all versions · fixed in 4.15.4-1
- linuxDebian:12all versions · fixed in 4.15.4-1
- linuxDebian:8all versions · fixed in 3.16.81-1
- linux-4.9Debian:8all versions · fixed in 4.9.210-1~deb8u1
- linux-awsUbuntu:Pro:14.04:LTSall versions · fixed in 4.4.0-1058.62
- linux-awsUbuntu:16.04:LTSall versions · fixed in 4.4.0-1098.109
13 more package ranges on OSV.dev
Vendor advisories
- CVE-2019-2215 Red Hat Product Security
kernel: Use-after-free in binder.c
Fix
- Update Huawei p20 lite firmware to 9.1.0.246\(c432e6r1p7t8\) · 9.1.0.201\(c636e4r1p5t8\) · 9.1.0.201\(zafc185e4r1p8t8\) · 9.1.0.200\(c605e4r1p3t8\) · 9.1.0.200\(c635e5r1p1t8\) · 9.1.0.200\(c636e4r1p5t8\)
- CISA’s required action: Apply updates per vendor instructions.due 2022-05-03
Advisories and patches
- packetstormsecurity.comPatch
- seclists.orgPatch
- source.android.comVendor Advisory
Detection
read 2026-11-03 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Proof-of-concept repositories
- 20 repositories, unverifiedtimwr/CVE-2019-2215kangtastic/cve-2019-2215ATorNinja/CVE-2019-2215LIznzn/CVE-2019-2215DimitriFourny/cve-2019-2215 PoC-in-GitHub
- Metasploit modules
- 1 moduleexploit/android/local/binder_uafrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
CISA Known Exploited Vulnerability
- Date Added
- 2021-11-03
- Patch Due Date
- 2022-05-03
- Ransomware Use
- Unknown
- Required Action
- Apply updates per vendor instructions.
Sources
- CISA KEVKEV entry2021-11-03
- ENISA EUVDexploitation2021-11-032021-11-03
- GCVEexploitation2021-11-03
- CISA-ADPSSVC decisionactive2025-02-07
- OpenCVESSVC decisionactive—
- CISA-ADPCVSS 3.17.82025-02-07
- NVDCVSS 3.17.8read 2026-10-23
- NVDCVSS 2.04.6read 2026-10-23
- CISA-ADPweakness (CWE)CWE-4162025-02-07
- NVDweakness (CWE)CWE-416read 2026-10-23
- FIRST EPSSEPSS score72.1 %read 2026-11-03
- PoC-in-GitHubproof of concept20read 2026-11-03
- Exploit-DBdetectionread 2026-11-03
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2019-11857same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-m7g6-9cwp-6jgmsame flawGitHub Advisory Database · CC-BY-4.0
- exploit/android/local/binder_uafexploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
- DLA-2068-1advisory covering several CVEsDebian · LicenseRef-unstated
- DLA-2114-1advisory covering several CVEsDebian · LicenseRef-unstated
- USN-4186-1advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Published
- 2019-10-11
- Last Modified
- 2026-06-17
- NVD status
- Analyzed
- GitHub Advisory
- GHSA-m7g6-9cwp-6jgm
Frequently asked questions
What is CVE-2019-2215?
Is CVE-2019-2215 actively exploited?
What is the CVSS score for CVE-2019-2215?
Running Linux kernel? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- For a threat intelligence platform: malware, C2 and ransomware indicators over STIX/TAXII.
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CISA KEV · CC0-1.0 (cisagov/kev-data)
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GCVE · GCVE dump terms (preserve source attribution)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-m7g6-9cwp-6jgm
- Metasploit Framework · BSD-3-Clause
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- PoC-in-GitHub · CC0-1.0
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0
- CISA Vulnrichment · CC0-1.0