Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-17558

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-12-30
  • Fixed in8.4.0 · 7.7.3
  • WeaknessCWE-74

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. A Velocity template can be provided through Velocity templates in a configset `velocity/` directory or as a parameter. A user defined configset could contain renderable, potentially malicious, templates. Parameter provided templates are disabled by default, but can be enabled by setting `params.resource.loader.enabled` by defining a response writer with that setting set to `true`. Defining a response writer requires configuration API access. Solr 8.4 removed the params resource loader entirely, and only enables the configset-provided template rendering when the configset is `trusted` (has been uploaded by an authenticated user).

Timeline

dates in UTC
  1. 2019-11-01Exploit-DB entryExploit-DB
  2. 2019-12-3017:15CVE publishedNVD
  3. 2021-11-03Added to the CISA KEV catalogCISA KEV
  4. 2021-11-03Listed as exploited by GCVEGCVE
  5. 2021-11-03Exploitation first reportedCISA KEV
  6. 2025-02-0621:05SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-17558?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-17558?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Apache solr
BranchAffectedFixed in
8.x≥ 8.0.0, < 8.4.08.4.0
8.4≥ 5.0.0, < 8.4.08.4.0
8.4≥ 6.0.0, < 8.4.08.4.0
8.4≥ 7.0.0, < 8.4.08.4.0
7.7≥ 5.0.0, < 7.7.37.7.3
Oracle primavera unifier
BranchAffectedFixed in
17.x≥ 17.7, ≤ 17.12no fix published
16.1= 16.1no fix published
16.2= 16.2no fix published
18.8= 18.8no fix published
19.12= 19.12no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As apache, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Apache Solr
    Affected
    • = Apache Solr 5.0.0 to Apache Solr 8.3.1no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-03-25

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • lucene-solrDebian:14all versions · no fixed version listed
  • lucene-solrDebian:13all versions · no fixed version listed
  • lucene-solrDebian:12all versions · no fixed version listed
  • org.apache.solr:solr-coreTuxCare:Mavenfrom 5.5.5 · fixed in 5.5.5-tuxcare.3

Vendor advisories

  • CVE-2019-17558 Red Hat Product Security

    solr: Remote Code Execution through the VelocityResponseWriter

Full record on NVD

Fix

  1. Update Apache solr to 8.4.0 · 7.7.3
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-47572EDB-48338
Exploit-DB
Metasploit modules
1 moduleexploit/multi/http/solr_velocity_rcerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2019-12-30
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-ww97-9w65-2crx

Frequently asked questions

What is CVE-2019-17558?

Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. A Velocity template can be provided through Velocity templates in a configset `velocity/` directory or as a parameter. A user defined configset could contain renderable, potentially malicious, templates. Parameter provided templates are disabled by default, but can be enabled by setting `params.resource.loader.enabled` by defining a response writer with that setting set to `true`. Defining a response writer requires configuration API access. Solr 8.4 removed the params resource loader entirely, and only enables the configset-provided template rendering when the configset is `trusted` (has been uploaded by an authenticated user).

Is CVE-2019-17558 actively exploited?

Yes. CVE-2019-17558 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2019-17558?

CVE-2019-17558 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running solr? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record