Skip to main content
Public proof of conceptFix available

CVE-2019-0192

A public proof of concept exists; no exploitation attested.

  • Published2019-03-07
  • WeaknessCWE-502

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Timeline

dates in UTC
  1. 2019-03-0721:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-0192?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-0192?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Apache solr
BranchAffectedFixed in
5.x≥ 5.0.0, ≤ 5.5.5no fix published
6.x≥ 6.0.0, ≤ 6.6.5no fix published
solr-core
BranchAffectedFixed in
7.0≥ 5.0.0, < 7.0.07.0.0
7.0≥ 6.0.0, < 7.0.07.0.0
Netapp storage automation store
BranchAffectedFixed in
—all versionsno fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • lucene-solrUbuntu:Pro:18.04:LTSall versions · no fixed version listed
  • lucene-solrUbuntu:Pro:16.04:LTSall versions · no fixed version listed
  • lucene-solrUbuntu:Pro:14.04:LTSall versions · no fixed version listed
  • lucene-solrUbuntu:26.10all versions · no fixed version listed
  • lucene-solrUbuntu:26.04:LTSall versions · no fixed version listed
  • lucene-solrUbuntu:25.10all versions · no fixed version listed
  • lucene-solrUbuntu:24.04:LTSall versions · no fixed version listed
  • lucene-solrUbuntu:22.04:LTSall versions · no fixed version listed

2 more package ranges on OSV.dev

Vendor advisories

  • CVE-2019-0192 Red Hat Product Security1 product fixed · 3 known affected

    solr: remote code execution due to unsafe deserialization

    solr-core as a component of Red Hat JBoss Data Grid 6 · solr-core as a component of Red Hat JBoss Fuse 6 · solr-core as a component of Red Hat JBoss Fuse Service Works 6

  • RHSA-2019:2413 Red Hat Product Security1 product fixed

    Red Hat Security Advisory: Red Hat Fuse 7.4.0 security update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2019:2413 · 1 productBefore applying the update, back up your existing installation, including all applications, configuration files, databases and database settings, and so on. Installation instructions are available from the Fuse 7.4.0 product documentation page: https://access.redhat.com/documentation/en-us/red_hat…
  2. Workaround from the vendor Red Hat Product Security RHSA-2019:2413 · 1 product* Upgrade to 6.6.6 or later * Disable the ConifgAPI if not in use (`disable.configEdit=true`) * Use other external means to ensure only trusted traffic is allowed (block POST requests to the config API from external sources)
  3. No fix available, says the vendor Red Hat Product Security CVE-2019-0192 · 1 productAffected
  4. No fix planned, says the vendor Red Hat Product Security CVE-2019-0192 · 2 productsOut of support scope

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedmpgn/CVE-2019-0192Rapidsafeguard/Solr-RCE-CVE-2019-0192
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-03-07
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-xhcq-fv7x-grr2

Frequently asked questions

What is CVE-2019-0192?

In Apache Solr versions 5.0.0 to 5.5.5 and 6.0.0 to 6.6.5, the Config API allows to configure the JMX server via an HTTP POST request. By pointing it to a malicious RMI server, an attacker could take advantage of Solr's unsafe deserialization to trigger remote code execution on the Solr side.

Is CVE-2019-0192 actively exploited?

Active exploitation of CVE-2019-0192 has not been confirmed. Its EPSS score was 78.2% on 2026-11-02, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-0192?

CVE-2019-0192 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running solr? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record