Skip to main content
No exploitation reportedFix available

CVE-2019-16905

No exploitation reported by the sources we read.

  • Published2019-10-09
  • Fixed in8.1
  • WeaknessCWE-190

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

OpenSSH 7.7 through 7.9 and 8.x before 8.1, when compiled with an experimental key type, has a pre-authentication integer overflow if a client or server is configured to use a crafted XMSS key. This leads to memory corruption and local code execution because of an error in the XMSS key parsing algorithm. NOTE: the XMSS implementation is considered experimental in all released OpenSSH versions, and there is no supported way to enable it when building portable OpenSSH.

Timeline

dates in UTC
  1. 2019-10-0920:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-10-28 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-16905?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-16905?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
OpenSSH
BranchAffectedFixed in
8.x≥ 8.0, < 8.18.1
7.x≥ 7.7, ≤ 7.9no fix published
Netapp cloud backup
BranchAffectedFixed in
—all versionsno fix published
Netapp steelstore cloud integrated storage
BranchAffectedFixed in
—all versionsno fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Vendor advisories

  • CVE-2019-16905 Red Hat Product Security

    openssh: an integer overflow in the private key parsing code for the XMSS key type

  • ICSA-23-348-10 CISA5 known affected

    Siemens SIMATIC S7-1500

    SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AB0) · SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AC0) · SIMATIC S7-1500 CPU 1518F-4 PN/DP MFP (6ES7518-4FX00-1AB0) · +2 more

  • SSA-398330 Siemens ProductCERT5 known affected

    SSA-398330: Vulnerabilities in the additional GNU/Linux subsystem of the SIMATIC S7-1500 CPU 1518(F)-4 PN/DP MFP >= V3.1.0 and < V3.1.5

    SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AB0) >= V3.1.0 < V3.1.5 · SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AC0) >= V3.1.0 < V3.1.5 · SIMATIC S7-1500 CPU 1518F-4 PN/DP MFP (6ES7518-4FX00-1AB0) >= V3.1.0 < V3.1.5 · +2 more

  • ICSA-22-349-21 CISA5 known affected

    Siemens SCALANCE X-200RNA Switch Devices

    SCALANCE X204RNA (HSR) (6GK5204-0BA00-2MB2) · SCALANCE X204RNA (PRP) (6GK5204-0BA00-2KB2) · SCALANCE X204RNA EEC (HSR) (6GK5204-0BS00-2NA3) · +2 more

  • SSA-412672 Siemens ProductCERT5 known affected

    SSA-412672: Multiple OpenSSL and OpenSSH Vulnerabilities in SCALANCE X-200RNA Switch Devices before V3.2.7

    SCALANCE X204RNA (HSR) (6GK5204-0BA00-2MB2) · SCALANCE X204RNA (PRP) (6GK5204-0BA00-2KB2) · SCALANCE X204RNA EEC (HSR) (6GK5204-0BS00-2NA3) · +2 more

Full record on NVD

Fix

  1. Update OpenSSH to 8.1
  2. Vendor fix CISA ICSA-23-348-10 · 5 productsUpdate to V3.1.5 or later version
  3. Vendor fix Siemens ProductCERT SSA-398330 · 1 productUpdate to V3.1.5 or later version
  4. Vendor fix Siemens ProductCERT SSA-412672 · 5 productsUpdate to V3.2.7 or later version
  5. Vendor fix CISA ICSA-22-349-21 · 5 productsUpdate to V3.2.7 or later version
  6. Workaround from the vendor Red Hat Product Security CVE-2019-16905 · 27 productsThis flaw is triggered when parsing XMSS private keys. XMSS is a PQC (Post-quantum cryptography) algorithm and its use is currently experimental. Other key types or any other OpenSSH functionality are not affected by this flaw. A possible mitigation for this flaw is to NOT use XMSS keys for SSH.
  7. Mitigation from the vendor CISA ICSA-23-348-10 · 5 productsOnly build and run applications from trusted sources.

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub

Sources

  • NVDCVSS 3.17.8read 2026-10-23
  • NVDCVSS 2.04.4read 2026-10-23
  • NVDweakness (CWE)CWE-190read 2026-10-23
  • FIRST EPSSEPSS score2.2 %2026-10-26

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2019-10-09
Last Modified
2026-10-14
NVD status
Modified

Frequently asked questions

What is CVE-2019-16905?

OpenSSH 7.7 through 7.9 and 8.x before 8.1, when compiled with an experimental key type, has a pre-authentication integer overflow if a client or server is configured to use a crafted XMSS key. This leads to memory corruption and local code execution because of an error in the XMSS key parsing algorithm. NOTE: the XMSS implementation is considered experimental in all released OpenSSH versions, and there is no supported way to enable it when building portable OpenSSH.

Is CVE-2019-16905 actively exploited?

Active exploitation of CVE-2019-16905 has not been confirmed. Its EPSS score was 2.2% on 2026-10-26, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-16905?

CVE-2019-16905 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running OpenSSH? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month