Skip to main content
No exploitation reportedFix available

CVE-2022-29155

No exploitation reported by the sources we read.

  • Published2022-05-04
  • Fixed in2.6.2 · 2.5.12
  • WeaknessCWE-89

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL statement within an LDAP query. This can occur during an LDAP search operation when the search filter is processed, due to a lack of proper escaping.

Timeline

dates in UTC
  1. 2022-05-0420:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-29155?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-29155?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Openldap
BranchAffectedFixed in
2.6≥ 2.6.0, < 2.6.22.6.2
2.x≥ 2.0, < 2.5.122.5.12
2.x≥ 2.0.0, < 2.5.122.5.12
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published
10.0= 10.0no fix published
11.0= 11.0no fix published
Netapp h300s firmwareversion to verify
BranchAffectedFixed in
—all versionsno fix published

5 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • openldapUbuntu:Pro:16.04:LTSall versions · fixed in 2.4.42+dfsg-2ubuntu3.13+esm1
  • openldapUbuntu:Pro:14.04:LTSall versions · fixed in 2.4.31-1+nmu2ubuntu8.5+esm5
  • openldapUbuntu:22.04:LTSall versions · fixed in 2.5.11+dfsg-1~exp1ubuntu3.1
  • openldapUbuntu:20.04:LTSall versions · fixed in 2.4.49+dfsg-2ubuntu1.9
  • openldapUbuntu:18.04:LTSall versions · fixed in 2.4.45+dfsg-1ubuntu1.11
  • openldapTuxCare:RHEL:7all versions · fixed in 2.4.44-25.el7_9.tuxcare.els1and 4 other packages
  • openldapTuxCare:OracleLinux:7all versions · fixed in 2.4.44-25.el7_9.tuxcare.els1and 4 other packages
  • openldapTuxCare:OracleLinux:6all versions · fixed in 2.4.40-16.el6.tuxcare.els2and 4 other packages

71 more package ranges on OSV.dev

Vendor advisories

  • CVE-2022-29155 Red Hat Product Security14 known affected

    openldap: OpenLDAP SQL injection

    compat-openldap as a component of Red Hat Enterprise Linux 6 · openldap as a component of Red Hat Enterprise Linux 6 · openldap-clients as a component of Red Hat Enterprise Linux 6 · +11 more

  • ICSA-23-348-10 CISA5 known affected

    Siemens SIMATIC S7-1500

    SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AB0) · SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AC0) · SIMATIC S7-1500 CPU 1518F-4 PN/DP MFP (6ES7518-4FX00-1AB0) · +2 more

  • SSA-398330 Siemens ProductCERT5 known affected

    SSA-398330: Vulnerabilities in the additional GNU/Linux subsystem of the SIMATIC S7-1500 CPU 1518(F)-4 PN/DP MFP >= V3.1.0 and < V3.1.5

    SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AB0) >= V3.1.0 < V3.1.5 · SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AC0) >= V3.1.0 < V3.1.5 · SIMATIC S7-1500 CPU 1518F-4 PN/DP MFP (6ES7518-4FX00-1AB0) >= V3.1.0 < V3.1.5 · +2 more

Full record on NVD

Fix

  1. Update Openldap to 2.6.2 · 2.5.12
  2. Vendor fix CISA ICSA-23-348-10 · 5 productsUpdate to V3.1.5 or later version
  3. Vendor fix Siemens ProductCERT SSA-398330 · 1 productUpdate to V3.1.5 or later version
  4. Mitigation from the vendor CISA ICSA-23-348-10 · 5 productsOnly build and run applications from trusted sources.
  5. No fix planned, says the vendor Red Hat Product Security CVE-2022-29155 · 8 productsOut of support scope
  6. No fix planned, says the vendor Red Hat Product Security CVE-2022-29155 · 6 productsWill not fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-05-04
Last Modified
2026-10-14
NVD status
Modified
GitHub Advisory
GHSA-9rm2-9q89-9524

Frequently asked questions

What is CVE-2022-29155?

In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL statement within an LDAP query. This can occur during an LDAP search operation when the search filter is processed, due to a lack of proper escaping.

Is CVE-2022-29155 actively exploited?

Active exploitation of CVE-2022-29155 has not been confirmed. Its EPSS score was 64.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2022-29155?

CVE-2022-29155 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running openldap? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record