Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-11580

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-06-03
  • Fixed in3.4.4 · 3.3.5 · 3.2.8 · 3.1.6 · 3.0.5

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

Timeline

dates in UTC
  1. 2019-06-0314:29CVE publishedNVD
  2. 2021-11-03Added to the CISA KEV catalogCISA KEV
  3. 2021-11-03Listed as exploited by GCVEGCVE
  4. 2021-11-03Exploitation first reportedCISA KEV
  5. 2025-02-0712:27SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-11580?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-11580?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Atlassian crowd
BranchAffectedFixed in
3.4≥ 3.4.0, < 3.4.43.4.4
3.3≥ 3.3.0, < 3.3.53.3.5
3.2≥ 3.2.0, < 3.2.83.2.8
3.1≥ 3.1.0, < 3.1.63.1.6
3.0≥ 2.1.0, < 3.0.53.0.5

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As atlassian, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Atlassian Crowd
    Affected
    • = 2.1.0no fix statedcustom
    • < 3.0.5fixed in 3.0.5custom
    • = 3.1.0no fix statedcustom
    • < 3.1.6fixed in 3.1.6custom
    • = 3.2.0no fix statedcustom
    • < 3.2.8fixed in 3.2.8custom
    • = 3.3.0no fix statedcustom
    • < 3.3.5fixed in 3.3.5custom

    2 more version lines in the CVE record.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-08-12

Fix

  1. Update Atlassian crowd to 3.4.4 · 3.3.5 · 3.2.8 · 3.1.6 · 3.0.5
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedjas502n/CVE-2019-11580shelld3v/CVE-2019-11580
PoC-in-GitHub
Metasploit modules
1 moduleexploit/multi/http/atlassian_crowd_pdkinstall_plugin_upload_rcerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-06-03
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-8977-4jwc-24g8

Frequently asked questions

What is CVE-2019-11580?

Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.

Is CVE-2019-11580 actively exploited?

Yes. CVE-2019-11580 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2019-11580?

CVE-2019-11580 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record