Skip to main content
ExploitedIn CISA KEVFix available

CVE-2018-13382

Exploitation confirmed. First attested on 2022-01-10 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2019-06-04
  • Fixed in6.0.5 · 5.6.9 · 5.4.11
  • WeaknessCWE-863

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An Improper Authorization vulnerability in Fortinet FortiOS 6.0.0 to 6.0.4, 5.6.0 to 5.6.8 and 5.4.1 to 5.4.10 and FortiProxy 2.0.0, 1.2.0 to 1.2.8, 1.1.0 to 1.1.6, 1.0.0 to 1.0.7 under SSL VPN web portal allows an unauthenticated attacker to modify the password of an SSL VPN web portal user via specially crafted HTTP requests

Timeline

dates in UTC
  1. 2019-06-0421:29CVE publishedNVD
  2. 2020-11-19Exploit-DB entryExploit-DB
  3. 2022-01-10Added to the CISA KEV catalogCISA KEV
  4. 2022-01-10Listed as exploited by GCVEGCVE
  5. 2022-01-10Exploitation first reportedCISA KEV
  6. 2024-10-2313:31SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-13382?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-13382?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Fortinet FortiOS
BranchAffectedFixed in
6.0≥ 6.0.0, < 6.0.56.0.5
5.6≥ 5.6.0, < 5.6.95.6.9
5.4≥ 5.4.1, < 5.4.115.4.11
Fortinet fortiproxy
BranchAffectedFixed in
1.2< 1.2.91.2.9
2.0= 2.0.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As fortinet, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Fortinet FortiOS, FortiProxy
    Affected
    • = FortiOS 6.0.0 to 6.0.4, 5.6.0 to 5.6.8, 5.4.1 to 5.4.10, FortiProxy 2.0.0, 1.2.0 to 1.2.8, 1.1.0 to 1.1.6, 1.0.0 to 1.0.7no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-06-03

Fix

  1. Update Fortinet FortiOS to 6.0.5 · 5.6.9 · 5.4.11
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-07-10

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-49074
Exploit-DB
Proof-of-concept repositories
3 repositories, unverifiedmilo2012/CVE-2018-13382tumikoto/Exploit-FortinetMagicBackdoorcojoben/CVE-2018-13382
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-01-10
Patch Due Date
2022-07-10
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Published
2019-06-04
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-chg2-j3mj-m3rj

Frequently asked questions

What is CVE-2018-13382?

An Improper Authorization vulnerability in Fortinet FortiOS 6.0.0 to 6.0.4, 5.6.0 to 5.6.8 and 5.4.1 to 5.4.10 and FortiProxy 2.0.0, 1.2.0 to 1.2.8, 1.1.0 to 1.1.6, 1.0.0 to 1.0.7 under SSL VPN web portal allows an unauthenticated attacker to modify the password of an SSL VPN web portal user via specially crafted HTTP requests

Is CVE-2018-13382 actively exploited?

Yes. CVE-2018-13382 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-07-10.

What is the CVSS score for CVE-2018-13382?

CVE-2018-13382 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record