Skip to main content
Public proof of conceptFix available

CVE-2019-1003005

A public proof of concept exists; no exploitation attested.

  • Published2019-02-06

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.50 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

Timeline

dates in UTC
  1. 2019-02-0616:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-1003005?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-1003005?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Jenkins script security
BranchAffectedFixed in
1.50≤ 1.50no fix published
script-security
BranchAffectedFixed in
1.51< 1.511.51

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • jenkins-2-pluginsRed Hat:openshift:3.11::el7all versions · fixed in 0:3.11.1552336312-1.el7

Vendor advisories

  • CVE-2019-1003005 Red Hat Product Security2 products fixed · 12 known affected

    jenkins-plugin-script-security: Sandbox Bypass in Script Security Plugin (SECURITY-1292)

    jenkins-plugin-script-security as a component of Red Hat OpenShift Container Platform 3.10 · jenkins-plugin-script-security.src as a component of Red Hat OpenShift Container Platform 3.10 · jenkins-plugin-script-security as a component of Red Hat OpenShift Container Platform 3.2 · +9 more

  • RHSA-2019:0739 Red Hat Product Security2 products fixed

    Red Hat Security Advisory: Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2019:0739 · 2 productsSee the following documentation, which will be updated shortly for release 3.11.98, for important instructions on how to upgrade your cluster and fully apply this asynchronous errata update: https://docs.openshift.com/container-platform/3.11/release_notes/ocp_3_11_release_notes.html This update i…
  2. No fix planned, says the vendor Red Hat Product Security CVE-2019-1003005 · 12 productsWill not fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/multi/http/jenkins_metaprogrammingrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2019-02-06
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-x5jm-rj37-5qh7

Frequently asked questions

What is CVE-2019-1003005?

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.50 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.

Is CVE-2019-1003005 actively exploited?

Active exploitation of CVE-2019-1003005 has not been confirmed. Its EPSS score was 19.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-1003005?

CVE-2019-1003005 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running jenkins-plugin-script-security? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record