Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-1003029

Exploitation confirmed. First attested on 2022-04-25 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2019-03-08

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.

Timeline

dates in UTC
  1. 2019-03-0821:29CVE publishedNVD
  2. 2022-04-25Added to the CISA KEV catalogCISA KEV
  3. 2022-04-25Listed as exploited by GCVEGCVE
  4. 2022-04-25Exploitation first reportedCISA KEV
  5. 2025-02-0713:06SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-1003029?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-1003029?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Jenkins script security
BranchAffectedFixed in
1.53≤ 1.53no fix published
Redhat openshift container platform
BranchAffectedFixed in
3.11= 3.11no fix published
script-security
BranchAffectedFixed in
1.54< 1.541.54

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As jenkins, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Jenkins project Jenkins Script Security Plugin
    Affected
    • = 1.53 and earlierno fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-10-24

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • jenkins-2-pluginsRed Hat:openshift:3.11::el7all versions · fixed in 0:3.11.1552336312-1.el7

Vendor advisories

  • CVE-2019-1003029 Red Hat Product Security2 products fixed · 10 known affected

    jenkins-plugin-script-security: sandbox bypass in script security plugin

    jenkins-2-plugins as a component of Red Hat OpenShift Container Platform 3.10 · jenkins-2-plugins.src as a component of Red Hat OpenShift Container Platform 3.10 · jenkins-plugin-script-security as a component of Red Hat OpenShift Container Platform 3.4 · +7 more

  • RHSA-2019:0739 Red Hat Product Security2 products fixed

    Red Hat Security Advisory: Red Hat OpenShift Container Platform 3.11 jenkins-2-plugins security update

Full record on NVD

Fix

  1. CISA’s required action: Apply updates per vendor instructions.due 2022-05-16
  2. Vendor fix Red Hat Product Security RHSA-2019:0739 · 2 productsSee the following documentation, which will be updated shortly for release 3.11.98, for important instructions on how to upgrade your cluster and fully apply this asynchronous errata update: https://docs.openshift.com/container-platform/3.11/release_notes/ocp_3_11_release_notes.html This update i…
  3. No fix planned, says the vendor Red Hat Product Security CVE-2019-1003029 · 10 productsWill not fix

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/multi/http/jenkins_metaprogrammingrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-04-25
Patch Due Date
2022-05-16
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Published
2019-03-08
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-xvxq-hq48-xphm

Frequently asked questions

What is CVE-2019-1003029?

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.

Is CVE-2019-1003029 actively exploited?

Yes. CVE-2019-1003029 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-16.

What is the CVSS score for CVE-2019-1003029?

CVE-2019-1003029 has a CVSS v3 base score of 9.9 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H.

Running jenkins-plugin-script-security? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record