Skip to main content
No exploitation reportedFix available

CVE-2018-25103

No exploitation reported by the sources we read.

  • Published2024-06-17

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

There exists use-after-free vulnerabilities in lighttpd <= 1.4.50 request parsing which might read from invalid pointers to memory used in the same request, not from other requests.

Timeline

dates in UTC
  1. 2024-06-1718:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-25103?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-25103?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

CISA-ADP
lighttpd
BranchAffectedFixed in
1.4≤ 1.4.50no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As certcc, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • lighttpd
    Affected
    • ≤ 1.4.50no fix statedcustom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2024-07-09

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • lighttpdUbuntu:Pro:18.04:LTSall versions · no fixed version listed
  • lighttpdUbuntu:Pro:16.04:LTSall versions · no fixed version listed
  • lighttpdUbuntu:Pro:14.04:LTSall versions · no fixed version listed
  • lighttpdDebian:14all versions · fixed in 1.4.52-1
  • lighttpdDebian:13all versions · fixed in 1.4.52-1
  • lighttpdDebian:12all versions · fixed in 1.4.52-1

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Published
2024-06-17
Last Modified
2026-06-17
NVD status
Deferred
GitHub Advisory
GHSA-844m-hq7r-wxc8

Frequently asked questions

What is CVE-2018-25103?

There exists use-after-free vulnerabilities in lighttpd <= 1.4.50 request parsing which might read from invalid pointers to memory used in the same request, not from other requests.

Is CVE-2018-25103 actively exploited?

Active exploitation of CVE-2018-25103 has not been confirmed. Its EPSS score was 0.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-25103?

CVE-2018-25103 has a CVSS v3 base score of 5.3 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N.

Running lighttpd? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record