CVE-2022-22707
No exploitation reported by the sources we read.
- Published2022-01-06
- WeaknessCWE-787
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.
Timeline
dates in UTC- 2022-01-0606:15CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-22707?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-22707?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 1.4 | ≥ 1.4.46, ≤ 1.4.63 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 10.0 | = 10.0 | no fix published | NVD |
| 11.0 | = 11.0 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- lighttpdUbuntu:22.04:LTSall versions · fixed in 1.4.63-1ubuntu3.1
- lighttpdUbuntu:20.04:LTSall versions · fixed in 1.4.55-1ubuntu1.20.04.2
- lighttpdSUSE:Package Hub 15 SP3all versions · fixed in 1.4.64-bp153.2.3.1
- lighttpdopenSUSE:Tumbleweedall versions · fixed in 1.4.64-1.1
- lighttpdopenSUSE:Leap 15.3all versions · fixed in 1.4.64-bp153.2.3.1
- lighttpdopenEuler:20.03-LTS-SP3all versions · fixed in 1.4.53-2.oe1
- lighttpdopenEuler:20.03-LTS-SP2all versions · fixed in 1.4.53-2.oe1
- lighttpdopenEuler:20.03-LTS-SP1all versions · fixed in 1.4.53-2.oe1
19 more package ranges on OSV.dev
Vendor advisories
- CVE-2022-22707 Red Hat Product Security
lighttpd: mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow
Fix
Advisories and patches
- redmine.lighttpd.netVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.15.9read 2026-10-23
- NVDCVSS 2.04.3read 2026-10-23
- NVDweakness (CWE)CWE-787read 2026-10-23
- FIRST EPSSEPSS score9.6 %2026-11-03
- OSVaffected packages—
Identifiers
- EUVD-2022-27850same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- DSA-5040-1advisory covering several CVEsDebian · LicenseRef-unstated
- MGASA-2022-0161advisory covering several CVEsMageia · LicenseRef-unstated
- OESA-2022-1491advisory covering several CVEsopenEuler · LicenseRef-unstated
- openSUSE-SU-2022:0024-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2024:11764-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- USN-5903-1advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Published
- 2022-01-06
- Last Modified
- 2026-06-17
- NVD status
- Modified
Frequently asked questions
What is CVE-2022-22707?
Is CVE-2022-22707 actively exploited?
What is the CVSS score for CVE-2022-22707?
Running lighttpd? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0