Skip to main content
Public proof of conceptFix available

CVE-2018-25031

A public proof of concept exists; no exploitation attested.

  • Published2022-03-11
  • Fixed in4.1.3
  • WeaknessCWE-20 · CWE-918 · CWE-922

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.

Timeline

dates in UTC
  1. 2022-03-1107:15CVE publishedNVD
  2. 2026-10-2319:23First public proof of conceptPoC-in-GitHub
  3. 2026-10-2319:23EPSS crossed 10 %FIRST EPSS

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-25031?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-25031?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV · CISA-ADP
Smartbear swagger ui
BranchAffectedFixed in
4.1< 4.1.34.1.3
4.1≤ 4.1.2no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • swagger-uiTuxCare:npmfrom 2.2.10-tuxcare.0 · fixed in 2.2.10-tuxcare.1

Full record on NVD

Fix

  1. Update Smartbear swagger ui to 4.1.3

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Published
2022-03-11
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-cr3q-pqgq-m8c2

Frequently asked questions

What is CVE-2018-25031?

Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.

Is CVE-2018-25031 actively exploited?

A proof-of-concept exploit exists for CVE-2018-25031, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2018-25031?

CVE-2018-25031 has a CVSS v3 base score of 4.3 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N.

Running swagger-ui? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record