Skip to main content
Public proof of conceptFix available

CVE-2022-24734

A public proof of concept exists; no exploitation attested.

  • Published2022-03-09
  • Fixed in1.8.30
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

MyBB is a free and open source forum software. In affected versions the Admin CP's Settings management module does not validate setting types correctly on insertion and update, making it possible to add settings of supported type `php` with PHP code, executed on on _Change Settings_ pages. This results in a Remote Code Execution (RCE) vulnerability. The vulnerable module requires Admin CP access with the `Can manage settings?` permission. MyBB's Settings module, which allows administrators to add, edit, and delete non-default settings, stores setting data in an options code string ($options_code; mybb_settings.optionscode database column) that identifies the setting type and its options, separated by a new line character (\n). In MyBB 1.2.0, support for setting type php was added, for which the remaining part of the options code is PHP code executed on Change Settings pages (reserved for plugins and internal use). MyBB 1.8.30 resolves this issue. There are no known workarounds.

Timeline

dates in UTC
  1. 2022-03-0922:15CVE publishedNVD
  2. 2022-05-11Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-24734?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-24734?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Mybb
BranchAffectedFixed in
1.x≥ 1.2.0, < 1.8.301.8.30

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • mybb
    Affected
    • = >= 1.2.0, < 1.8.30no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-05-31

Fix

  1. Update Mybb to 1.8.30

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-50924
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedAltelus1/CVE-2022-24734lavclash75/mybb-CVE-2022-24734
PoC-in-GitHub
Metasploit modules
1 moduleexploit/multi/http/mybb_rce_cve_2022_24734rank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Published
2022-03-09
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-876v-gwgh-w57f

Frequently asked questions

What is CVE-2022-24734?

MyBB is a free and open source forum software. In affected versions the Admin CP's Settings management module does not validate setting types correctly on insertion and update, making it possible to add settings of supported type `php` with PHP code, executed on on _Change Settings_ pages. This results in a Remote Code Execution (RCE) vulnerability. The vulnerable module requires Admin CP access with the `Can manage settings?` permission. MyBB's Settings module, which allows administrators to add, edit, and delete non-default settings, stores setting data in an options code string ($options_code; mybb_settings.optionscode database column) that identifies the setting type and its options, separated by a new line character (\n). In MyBB 1.2.0, support for setting type php was added, for which the remaining part of the options code is PHP code executed on Change Settings pages (reserved for plugins and internal use). MyBB 1.8.30 resolves this issue. There are no known workarounds.

Is CVE-2022-24734 actively exploited?

A proof-of-concept exploit exists for CVE-2022-24734, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-24734?

CVE-2022-24734 has a CVSS v3 base score of 7.2 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H.

Running mybb? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record