Skip to main content
Public proof of conceptFix available

CVE-2018-11218

A public proof of concept exists; no exploitation attested.

  • Published2018-06-17
  • Fixed in4.0.10 · 3.2.12
  • WeaknessCWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Memory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis before 3.2.12, 4.x before 4.0.10, and 5.x before 5.0 RC2 because of stack-based buffer overflows.

Timeline

dates in UTC
  1. 2018-06-1717:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-11218?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-11218?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Redislabs redis
BranchAffectedFixed in
4.0≥ 4.0, < 4.0.104.0.10
3.2< 3.2.123.2.12
5.0= 5.0no fix published
Oracle communications operations monitor
BranchAffectedFixed in
3.4= 3.4no fix published
4.0= 4.0no fix published
Redhat openstack
BranchAffectedFixed in
10.x= 10no fix published
13.x= 13no fix published

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • redisUbuntu:18.04:LTSall versions · fixed in 5:4.0.9-1ubuntu0.1
  • redisUbuntu:16.04:LTSall versions · fixed in 2:3.0.6-1ubuntu0.2
  • redisUbuntu:14.04:LTSall versions · fixed in 2:2.8.4-2ubuntu0.2
  • redisSUSE:Linux Enterprise Module for Server Applications 15 SP2all versions · fixed in 6.0.8-1.3.1
  • redisRed Hat:openstack:13::el7all versions · fixed in 0:3.2.8-3.el7ostand 1 other package
  • redisRed Hat:openstack:10::el7all versions · fixed in 0:3.0.6-4.el7ostand 1 other package
  • redisopenSUSE:Tumbleweedall versions · fixed in 6.2.5-1.2
  • redisMageia:6all versions · fixed in 4.0.10-1.mga6

10 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-11218 Red Hat Product Security29 products fixed · 12 known affected

    redis: Heap corruption in lua_cmsgpack.c

    redis as a component of Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) · redis.src as a component of Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) · redis as a component of Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) Operational Tools · +9 more

  • ICSMA-21-187-01 CISA4 known affected

    Philips Vue PACS (Update B)

    Vue PACS: Versions 12.2.x.x and prior · Vue Motion: Versions 12.2.1.5 and prior · Vue MyVue: Versions 12.2.x.x and prior · +1 more

  • RHSA-2019:1860 Red Hat Product Security21 products fixed

    Red Hat Security Advisory: rh-redis32-redis security update

  • RHSA-2019:0094 Red Hat Product Security5 products fixed

    Red Hat Security Advisory: redis security update

  • RHSA-2019:0052 Red Hat Product Security3 products fixed

    Red Hat Security Advisory: redis security update

Full record on NVD

Fix

  1. Update Redislabs redis to 4.0.10 · 3.2.12
  2. Vendor fix CISA ICSMA-21-187-01 · 1 productPhilips recommends configuring the Vue PACS environment per D000763414 - Vue_PACS_12_Ports_Protocols_Services_Guide available on Incenter.
  3. Vendor fix CISA ICSMA-21-187-01 · 1 productPhilips released Version 12.2.1.5 in June of 2020 for MyVue that remediates CWE-693 and recommends contacting support below.
  4. Vendor fix CISA ICSMA-21-187-01 · 1 productPhilips released Version 12.2.1.5 in June of 2020 for Vue Motion that remediates CWE-324 and recommends contacting support below.
  5. Vendor fix CISA ICSMA-21-187-01 · 1 productPhilips released Version 12.2.8.0 in May of 2021 for Speech that remediates CWE-693, CWE-319, CWE-119, CWE-287, and CWE-1214 and recommends contacting support below.
  6. Vendor fix CISA ICSMA-21-187-01 · 1 productPhilips released Version 12.2.8.0 in May of 2021 for PACS that remediates CWE-20, CWE-119, CWE-287 and recommends contacting support below.
  7. Vendor fix CISA ICSMA-21-187-01 · 1 productPhilips released a security fix for Speech in Nov 2021 that remediates CWE-665 and CWE-327 and recommends contacting support below.

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/linux/redis/redis_replication_cmd_execrank: goodModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • NVDCVSS 3.09.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • NVDweakness (CWE)CWE-787read 2026-10-23
  • FIRST EPSSEPSS score58.8 %read 2026-11-03
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2018-06-17
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-11218?

Memory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis before 3.2.12, 4.x before 4.0.10, and 5.x before 5.0 RC2 because of stack-based buffer overflows.

Is CVE-2018-11218 actively exploited?

Active exploitation of CVE-2018-11218 has not been confirmed. Its EPSS score was 58.8% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-11218?

CVE-2018-11218 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running Redis? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record