Skip to main content
No exploitation reportedFix available

CVE-2016-7076

No exploitation reported by the sources we read.

  • Published2018-05-29
  • WeaknessCWE-184 · CWE-77

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

sudo before version 1.8.18p1 is vulnerable to a bypass in the sudo noexec restriction if application run via sudo executed wordexp() C library function with a user supplied argument. A local user permitted to run such application via sudo with noexec restriction could possibly use this flaw to execute arbitrary commands with elevated privileges.

Timeline

dates in UTC
  1. 2018-05-2913:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-7076?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-7076?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Sudo project sudo
BranchAffectedFixed in
1.x≥ 1.6.8, ≤ 1.8.18no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • sudoUbuntu:Pro:14.04:LTSall versions · fixed in 1.8.9p5-1ubuntu1.5+esm5
  • sudoUbuntu:16.04:LTSall versions · fixed in 1.8.16-0ubuntu1.6
  • sudoSUSE:Linux Enterprise Software Development Kit 12 SP2all versions · fixed in 1.8.10p3-8.1
  • sudoSUSE:Linux Enterprise Software Development Kit 12 SP1all versions · fixed in 1.8.10p3-2.6.1
  • sudoSUSE:Linux Enterprise Server for SAP Applications 12 SP2all versions · fixed in 1.8.10p3-8.1
  • sudoSUSE:Linux Enterprise Server for SAP Applications 12 SP1all versions · fixed in 1.8.10p3-2.6.1
  • sudoSUSE:Linux Enterprise Server for SAP Applications 11 SP4all versions · fixed in 1.7.6p2-0.29.1
  • sudoSUSE:Linux Enterprise Server for Raspberry Pi 12 SP2all versions · fixed in 1.8.10p3-8.1

19 more package ranges on OSV.dev

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 3.06.4known since 2026-10-23
  • NVDCVSS 3.07.8read 2026-10-23
  • NVDCVSS 2.07.2read 2026-10-23
  • CNAweakness (CWE)CWE-184known since 2026-10-23
  • NVDweakness (CWE)CWE-77read 2026-10-23
  • FIRST EPSSEPSS score0.5 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2018-05-29
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2016-7076?

sudo before version 1.8.18p1 is vulnerable to a bypass in the sudo noexec restriction if application run via sudo executed wordexp() C library function with a user supplied argument. A local user permitted to run such application via sudo with noexec restriction could possibly use this flaw to execute arbitrary commands with elevated privileges.

Is CVE-2016-7076 actively exploited?

Active exploitation of CVE-2016-7076 has not been confirmed. Its EPSS score was 0.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-7076?

CVE-2016-7076 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running sudo? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record