Skip to main content
ExploitedIn CISA KEVFix available

CVE-2016-20017

Exploitation confirmed. First attested on 2024-01-05 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2022-10-19
  • Fixed in1.05
  • WeaknessCWE-77

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

D-Link DSL-2750B devices before 1.05 allow remote unauthenticated command injection via the login.cgi cli parameter, as exploited in the wild in 2016 through 2022.

Timeline

dates in UTC
  1. 2022-10-1905:15CVE publishedNVD
  2. 2024-01-0505:00Exploitation first reportedCISA-ADP
  3. 2024-01-0505:00SSVC exploitation set to activeCISA-ADP
  4. 2024-01-08Added to the CISA KEV catalogCISA KEV
  5. 2024-01-08Listed as exploited by GCVEGCVE

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-20017?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-20017?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Dlink dsl-2750b firmwareversion to verify
BranchAffectedFixed in
1.5< 1.051.05

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Dlink dsl-2750b firmware to 1.05
  2. CISA’s required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.due 2024-01-29

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/linux/http/dlink_dsl2750b_exec_noauthrank: greatModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2024-01-08
Patch Due Date
2024-01-29
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-10-19
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-4gf4-mg8f-6224

Frequently asked questions

What is CVE-2016-20017?

D-Link DSL-2750B devices before 1.05 allow remote unauthenticated command injection via the login.cgi cli parameter, as exploited in the wild in 2016 through 2022.

Is CVE-2016-20017 actively exploited?

Yes. CVE-2016-20017 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2024-01-29.

What is the CVSS score for CVE-2016-20017?

CVE-2016-20017 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record