CVE-2026-74846
Catalyst::Plugin::Authentication versions before 0.10029 for Perl allow timing attacks on stored passwords via eq comparisons in the legacy password verifier
No exploitation reported by the sources we read.
- Published2026-11-03
- WeaknessCWE-208
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Catalyst::Plugin::Authentication versions before 0.10029 for Perl allow timing attacks on stored passwords via eq comparisons in the legacy password verifier. CVE-2026-5091 was fixed in the realm-based verifier. The legacy verifier, used by the deprecated login method, compares clear-text passwords, crypt hashes and base64 digests with eq, so the comparison time depends on how many leading bytes match. A remote attacker can use response-time differences to guess the stored password or hash.
Timeline
dates in UTC- 2026-11-0307:51CVE publishedCNA
Versions per branch
Products declared by the CNA1 product
As CPANSec, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Catalyst-Plugin-Authenticationother versions: not affectedAffected
- < 0.10029fixed in 0.10029custom
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-11-03
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- libcatalyst-plugin-authentication-perlUbuntu:26.10all versions · no fixed version listed
- libcatalyst-plugin-authentication-perlUbuntu:26.04:LTSall versions · no fixed version listed
- libcatalyst-plugin-authentication-perlUbuntu:24.04:LTSall versions · no fixed version listed
- libcatalyst-plugin-authentication-perlUbuntu:22.04:LTSall versions · no fixed version listed
- libcatalyst-plugin-authentication-perlUbuntu:20.04:LTSall versions · no fixed version listed
- libcatalyst-plugin-authentication-perlUbuntu:18.04:LTSall versions · no fixed version listed
- libcatalyst-plugin-authentication-perlUbuntu:16.04:LTSall versions · no fixed version listed
- libcatalyst-plugin-authentication-perlDebian:14all versions · no fixed version listed
2 more package ranges on OSV.dev
Vendor advisories
- CVE-2026-74846 Red Hat Product Security
perl-catalyst-plugin-authentication: Catalyst::Plugin::Authentication: Information disclosure via timing attack in password verification
Fix
No fix published by the sources we read yet. NVD record
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof of concept
- PoC-in-GitHubno public repository identifiedread 2026-11-06
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVE recordread 2026-11-06
- CISA-ADPSSVC decisionnone2026-11-06
- CISA-ADPCVSS 3.17.52026-11-06
- CNAweakness (CWE)CWE-2082026-11-03
- FIRST EPSSEPSS score0.3 %2026-11-05
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2026-115722same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-p4f5-m8h6-x7p5same flawGitHub Advisory Database · CC-BY-4.0
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Published
- 2026-11-03
- Last Modified
- 2026-11-06
- NVD status
- Awaiting Analysis
- GitHub Advisory
- GHSA-p4f5-m8h6-x7p5
Frequently asked questions
What is CVE-2026-74846?
Is CVE-2026-74846 actively exploited?
What is the CVSS score for CVE-2026-74846?
Running perl-catalyst-plugin-authenticat? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
- CVE-2009-10007same product
- CVE-2026-5091same product
- CVE-2026-118527KEVsame week
- CVE-2026-19868KEVsame week
- CVE-2026-77690same weekCommand injection vulnerability
- CVE-2026-121943same weekIrontec sngrep through 1.9.0 Out-of-Bounds Stack Read via sip_check_packet
- CVE-2026-119742same weekNagios XI < 2026R2 OS Command Injection via mibs.php
- CVE-2026-120276same weekWAVLINK WN536AX6-A Web Management ioos sub_416760 os command injection
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-p4f5-m8h6-x7p5
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0
- CISA Vulnrichment · CC0-1.0