Skip to main content
No exploitation reportedFix available

CVE-2009-10007

No exploitation reported by the sources we read.

  • Published2026-06-09
  • WeaknessCWE-384

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Catalyst::Plugin::Authentication versions before 0.10_027 for Perl is susceptible to session fixation attacks. Catalyst::Plugin::Authentication does not automatically change the session id after authentication. An attacker that obtains a session id cookie can use this to impersonate the victim.

Timeline

dates in UTC
  1. 2026-06-0909:16CVE publishedNVD

Versions per branch

Products declared by the CNA1 product

As CPANSec, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • ETHER Catalyst::Plugin::Authenticationother versions: not affected

    package Catalyst-Plugin-Authenticationhttps://cpan.org/modules

    Affected
    • < 0.10_027fixed in 0.10_027custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-06-09

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libcatalyst-plugin-authentication-perlUbuntu:26.10all versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:26.04:LTSall versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:25.10all versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:24.04:LTSall versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:22.04:LTSall versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:20.04:LTSall versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:18.04:LTSall versions · no fixed version listed
  • libcatalyst-plugin-authentication-perlUbuntu:16.04:LTSall versions · no fixed version listed

5 more package ranges on OSV.dev

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Published
2026-06-09
Last Modified
2026-07-21
NVD status
Deferred
GitHub Advisory
GHSA-pfqm-wq4x-p42c

Frequently asked questions

What is CVE-2009-10007?

Catalyst::Plugin::Authentication versions before 0.10_027 for Perl is susceptible to session fixation attacks. Catalyst::Plugin::Authentication does not automatically change the session id after authentication. An attacker that obtains a session id cookie can use this to impersonate the victim.

Is CVE-2009-10007 actively exploited?

Active exploitation of CVE-2009-10007 has not been confirmed. Its EPSS score was 0.4% on 2026-11-05, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2009-10007?

CVE-2009-10007 has a CVSS v3 base score of 9.1 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.

Running perl-Catalyst-Plugin-Authenticat? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record