Skip to main content
No exploitation reportedFix available

CVE-2026-39922

No exploitation reported by the sources we read.

  • Published2026-04-10
  • Fixed in5.0.2 · 4.4.5
  • WeaknessCWE-918

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the service registration endpoint that allows authenticated attackers to trigger outbound network requests to arbitrary URLs by submitting a crafted service URL during form validation. Attackers can probe internal network targets including loopback addresses, RFC1918 private IP ranges, link-local addresses, and cloud metadata services by exploiting insufficient URL validation in the WMS service handler without private IP filtering or allowlist enforcement.

Timeline

dates in UTC
  1. 2026-04-1020:16CVE publishedNVD

Versions per branch

NVD · OSV
Geosolutionsgroup geonode
BranchAffectedFixed in
5.0≥ 5.0.0, < 5.0.25.0.2
4.x≥ 4.0.0, < 4.4.54.4.5

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As VulnCheck, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-10-08

Fix

  1. Update Geosolutionsgroup geonode to 5.0.2 · 4.4.5

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionnone2026-04-13
  • CNACVSS 4.05.3known since 2026-10-23
  • NVDCVSS 3.16.3read 2026-10-23
  • CNAweakness (CWE)CWE-918known since 2026-10-23
  • FIRST EPSSEPSS score0.2 %2026-11-05
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryMODERATE2026-06-08

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2026-04-10
Last Modified
2026-10-08
NVD status
Modified

Frequently asked questions

What is CVE-2026-39922?

GeoNode versions 4.4.5 and 5.0.2 (and prior within their respective releases) contain a server-side request forgery vulnerability in the service registration endpoint that allows authenticated attackers to trigger outbound network requests to arbitrary URLs by submitting a crafted service URL during form validation. Attackers can probe internal network targets including loopback addresses, RFC1918 private IP ranges, link-local addresses, and cloud metadata services by exploiting insufficient URL validation in the WMS service handler without private IP filtering or allowlist enforcement.

Is CVE-2026-39922 actively exploited?

Active exploitation of CVE-2026-39922 has not been confirmed. Its EPSS score was 0.2% on 2026-11-05, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2026-39922?

CVE-2026-39922 has a CVSS v3 base score of 6.3 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L.

Running geonode? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record