CVE-2023-40017
No exploitation reported by the sources we read.
- Published2023-08-24
- Fixed in4.2.0 · 4.1.3
- WeaknessCWE-918
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. In versions 3.2.0 through 4.1.2, the endpoint `/proxy/?url=` does not properly protect against server-side request forgery. This allows an attacker to port scan internal hosts and request information from internal hosts. A patch is available at commit a9eebae80cb362009660a1fd49e105e7cdb499b9.
Timeline
dates in UTC- 2023-08-2423:15CVE publishedNVD
Versions per branch
OSV · NVD · CISA-ADP| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 4.2 | ≥ 3.2.0, < 4.2.0 | 4.2.0 | OSV |
| 4.1 | ≥ 3.2.0, < 4.1.3 | 4.1.3 | OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 4.1 | ≥ 3.2.0, ≤ 4.1.2 | no fix published | NVD · CISA-ADP |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- geonodeAffected
- = >= 3.2.0, <= 4.1.2no fix stated
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-08-24
Fix
- Update geonode to 4.2.0 · 4.1.3
Advisories and patches
- github.comPatch
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof of concept
- PoC-in-GitHubno public repository identifiedread 2026-11-06
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionnone2024-10-02
- CNACVSS 3.17.5known since 2026-10-23
- NVDCVSS 3.17.5read 2026-10-23
- CNAweakness (CWE)CWE-918known since 2026-10-23
- FIRST EPSSEPSS score0.8 %2026-11-05
- OSVaffected packages—
- GitHub AdvisoriesadvisoryHIGH2024-11-21
Identifiers
- EUVD-2023-0083same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-rmxg-6qqf-x8mrsame flawGitHub Advisory Database · CC-BY-4.0
- PYSEC-2023-269same flawPyPA Advisory Database · CC-BY-4.0
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Published
- 2023-08-24
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-rmxg-6qqf-x8mr
Frequently asked questions
What is CVE-2023-40017?
Is CVE-2023-40017 actively exploited?
What is the CVSS score for CVE-2023-40017?
Running geonode? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-rmxg-6qqf-x8mr
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- CISA Vulnrichment · CC0-1.0