Skip to main content
No exploitation reportedAwaiting NVD analysis

CVE-2026-119749

GetPaid WordPress Plugin < 2.8.63 Negative Quantity Payment Bypass

No exploitation reported by the sources we read.

  • Published2026-11-04
  • WeaknessCWE-1284

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The GetPaid plugin for WordPress before 2.8.63 contains an improper input validation vulnerability that allows unauthenticated attackers to bypass payment processing by submitting a negative item quantity on a public payment form. Attackers can exploit the unchecked quantity value in process_item() to produce a negative line subtotal that reduces the invoice total to zero, causing process_free_payment() to mark the invoice as paid without any actual gateway charge.

Timeline

dates in UTC
  1. 2026-11-0416:52CVE publishedCNA

Versions per branch

Products declared by the CNA

As VulnCheck, the CNA that assigned this CVE, declared them in the CVE record; versions as written. NVD lists no product for this CVE yet: this is the only product data so far.

  • AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaidother versions: not affected
    Affected
    • < 2.8.63fixed in 2.8.63semver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-11-04

Neither OSV.dev nor the vendor advisories we read list affected versions for CVE-2026-119749 yet.

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionnone2026-11-04
  • CNACVSS 4.08.72026-11-04
  • CNACVSS 3.17.52026-11-04
  • NVDCVSS 3.17.5read 2026-11-04
  • CNAweakness (CWE)CWE-12842026-11-04
  • NVDweakness (CWE)CWE-1284read 2026-11-04
  • GitHub Advisoriesadvisory—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2026-11-04
Last Modified
2026-11-04
NVD status
Received
GitHub Advisory
GHSA-mxp8-89wv-42r2

Frequently asked questions

What is CVE-2026-119749?

The GetPaid plugin for WordPress before 2.8.63 contains an improper input validation vulnerability that allows unauthenticated attackers to bypass payment processing by submitting a negative item quantity on a public payment form. Attackers can exploit the unchecked quantity value in process_item() to produce a negative line subtotal that reduces the invoice total to zero, causing process_free_payment() to mark the invoice as paid without any actual gateway charge.

Is CVE-2026-119749 actively exploited?

Active exploitation of CVE-2026-119749 has not been confirmed.

What is the CVSS score for CVE-2026-119749?

CVE-2026-119749 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record