Skip to main content
No exploitation reportedFix available

CVE-2026-118370

libexpat through 2.9.0 Integer Overflow in storeAtts via attIndex and nPrefixes

No exploitation reported by the sources we read.

  • Published2026-10-28
  • WeaknessCWE-190

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

libexpat through 2.9.0 contains a signed integer overflow vulnerability in storeAtts() in lib/xmlparse.c that allows attackers to trigger out-of-bounds writes via oversized attribute counts. Attackers can supply a multi-gigabyte document with a start tag carrying over 2^30 attributes to overflow attIndex and nPrefixes, crashing applications or corrupting heap memory.

Timeline

dates in UTC
  1. 2026-10-2803:17CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-02 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2026-118370?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2026-118370?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Libexpat project libexpat
BranchAffectedFixed in
2.9≤ 2.9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • cmakeAzure Linux:3all versions · no fixed version listedand 1 other package
  • coin3Ubuntu:Pro:18.04:LTSall versions · no fixed version listedand 4 other packages
  • expatUbuntu:Pro:20.04:LTSall versions · no fixed version listedand 3 other packages
  • expatEchoall versions · fixed in 2.9.0-1+e5
  • expatDebian:14all versions · no fixed version listed
  • expatDebian:13all versions · no fixed version listed
  • expatDebian:12all versions · no fixed version listed
  • expatAlpine:v3.24all versions · fixed in 2.10.0-r0

15 more package ranges on OSV.dev

Full record on NVD

Fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 4.08.2read 2026-11-02
  • CNACVSS 3.15.9read 2026-11-02
  • NVDCVSS 3.18.2read 2026-11-02
  • NVDweakness (CWE)CWE-190read 2026-11-02
  • FIRST EPSSEPSS score0.4 %2026-11-02
  • OSVaffected packages—
  • GitHub Advisoriesadvisory—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
CVSS 4.0 vector
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
2026-10-28
Last Modified
2026-11-02
NVD status
Analyzed
GitHub Advisory
GHSA-c6pw-vjr4-wwwr

Frequently asked questions

What is CVE-2026-118370?

libexpat through 2.9.0 contains a signed integer overflow vulnerability in storeAtts() in lib/xmlparse.c that allows attackers to trigger out-of-bounds writes via oversized attribute counts. Attackers can supply a multi-gigabyte document with a start tag carrying over 2^30 attributes to overflow attIndex and nPrefixes, crashing applications or corrupting heap memory.

Is CVE-2026-118370 actively exploited?

Active exploitation of CVE-2026-118370 has not been confirmed. Its EPSS score was 0.4% on 2026-11-02, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2026-118370?

CVE-2026-118370 has a CVSS v3 base score of 8.2 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H.

Running vtk? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record