CVE-2024-5617
Account Lock Bypass via User Store Synchronization in Multiple WSO2 Products Allows Brute Force Attacks
No exploitation reported by the sources we read.
- Published2026-11-02
- WeaknessCWE-799
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
The account lock feature fails to correctly enforce account lockouts on the primary user store when users with identical usernames exist in both primary and secondary user stores. This occurs because the lock condition is only applied to the secondary user store account in such scenarios, allowing continued authentication attempts against the primary user store account. This functional flaw enables brute force attacks. By systematically attempting different passwords against the primary user store account, an attacker can potentially gain unauthorized access to sensitive information or accounts, as the intended account lockout mechanism does not prevent repeated login attempts.
Timeline
dates in UTC- 2026-11-0205:57CVE publishedCNA
Observed activity
isMalicious corpus · updated 2026-11-02 03:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2024-5617?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2024-5617?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
Products declared by the CNA
As WSO2, the CNA that assigned this CVE, declared them in the CVE record; versions as written. NVD lists no product for this CVE yet: this is the only product data so far.
- WSO2 API Managerother versions: not affectedAffected
- ≥ 4.0.0, < 4.0.0.298fixed in 4.0.0.298custom
- ≥ 4.2.0, < 4.2.0.95fixed in 4.2.0.95custom
- ≥ 4.3.0, < 4.3.0.13fixed in 4.3.0.13custom
Not affected < 4.0.0 (status unknown)
- WSO2 Identity Serverother versions: not affectedAffected
- ≥ 5.11.0, < 5.11.0.348fixed in 5.11.0.348custom
- ≥ 6.0.0, < 6.0.0.194fixed in 6.0.0.194custom
- ≥ 6.1.0, < 6.1.0.162fixed in 6.1.0.162custom
- ≥ 7.0.0, < 7.0.0.33fixed in 7.0.0.33custom
Not affected < 5.11.0 (status unknown)
- WSO2 Carbon Identity Managementother versions: unknown
package org.wso2.carbon.identity.mgt
Affected- ≥ 5.18.187, < 5.18.187.259fixed in 5.18.187.259custom
- ≥ 5.23.8, < 5.23.8.180fixed in 5.23.8.180custom
- ≥ 5.24.8, < 5.24.8.5fixed in 5.24.8.5custom
- ≥ 5.25.92, < 5.25.92.84fixed in 5.25.92.84custom
- ≥ 5.25.705, < 5.25.705.5fixed in 5.25.705.5custom
- ≥ 7.0.78, < 7.0.78.19fixed in 7.0.78.19custom
- WSO2 Carbon User Manager Kernelother versions: unknown
package org.wso2.carbon:org.wso2.carbon.user.core
Affected- ≥ 4.6.1, < 4.6.1.114fixed in 4.6.1.114custom
- ≥ 4.7.1, < 4.7.1.53fixed in 4.7.1.53custom
- ≥ 4.8.1, < 4.8.1.16fixed in 4.8.1.16custom
- ≥ 4.9.0, < 4.9.0.58fixed in 4.9.0.58custom
- ≥ 4.9.26, < 4.9.26.7fixed in 4.9.26.7custom
- ≥ 4.10.9, < 4.10.9.17fixed in 4.10.9.17custom
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-11-02
Neither OSV.dev nor the vendor advisories we read list affected versions for CVE-2024-5617 yet.
Fix
No fix published by the sources we read yet. NVD record
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- Published
- 2026-11-02
- Last Modified
- 2026-11-02
- NVD status
- Received
Frequently asked questions
What is CVE-2024-5617?
Is CVE-2024-5617 actively exploited?
What is the CVSS score for CVE-2024-5617?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.