Skip to main content
No exploitation reportedFix available

CVE-2024-38477

No exploitation reported by the sources we read.

  • Published2024-07-01
  • Fixed in2.4.60
  • WeaknessCWE-476

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Timeline

dates in UTC
  1. 2024-07-0119:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-10-28 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2024-38477?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2024-38477?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Apache HTTP Server
BranchAffectedFixed in
2.4≥ 2.4.0, < 2.4.602.4.60
Netapp clustered data ontap
BranchAffectedFixed in
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • httpdAlmaLinux:9all versions · fixed in 2.4.57-11.el9_4and 8 other packages
  • httpdAlmaLinux:8all versions · fixed in 2.4.37-65.module_el8.10.0+3872+9b8ab21e.1and 6 other packages
  • mod_http2AlmaLinux:8all versions · fixed in 1.15.7-10.module_el8.10.0+3832+564e7653
  • mod_mdAlmaLinux:8all versions · fixed in 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
  • mod_mdAlmaLinux:8all versions · fixed in 1:2.0.8-8.module_el8.6.0+3031+fb177b09
  • mod_sslAlmaLinux:9all versions · fixed in 1:2.4.57-11.el9_4and 1 other package
  • mod_sslAlmaLinux:8all versions · fixed in 1:2.4.37-65.module_el8.10.0+3872+9b8ab21e.1and 1 other package

Full record on NVD

Fix

  1. Update Apache HTTP Server to 2.4.60

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub

Sources

  • CISA-ADPSSVC decisionnone2024-07-22
  • OpenCVESSVC decisionnone—
  • CISA-ADPCVSS 3.17.52024-07-22
  • NVDCVSS 3.17.5read 2026-10-23
  • CNAweakness (CWE)CWE-476read 2026-10-23
  • FIRST EPSSEPSS score3.2 %2026-10-26
  • OSVaffected packages—

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
2024-07-01
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2024-38477?

null pointer dereference in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows an attacker to crash the server via a malicious request. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Is CVE-2024-38477 actively exploited?

Active exploitation of CVE-2024-38477 has not been confirmed. Its EPSS score was 3.2% on 2026-10-26, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2024-38477?

CVE-2024-38477 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running Apache HTTP Server? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month