Skip to main content
Public proof of conceptFix available

CVE-2024-27758

A public proof of concept exists; no exploitation attested.

  • Published2024-03-12
  • Fixed in6.0.0
  • WeaknessCWE-306

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class that results in remote code execution.

Timeline

dates in UTC
  1. 2024-03-1216:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2024-27758?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2024-27758?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

CISA-ADP · OSV
Rpyc project rpyc
BranchAffectedFixed in
6.0< 6.0.06.0.0
6.0≥ 4.0.0, < 6.0.06.0.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • python-rpycSUSE:Package Hub 15 SP5all versions · fixed in 4.1.5-bp155.3.3.1and 1 other package
  • python-rpycopenSUSE:Tumbleweedall versions · fixed in 6.0.2-1.5
  • python-rpycopenSUSE:Leap 15.5all versions · fixed in 4.1.5-bp155.3.3.1and 1 other package
  • rpycUbuntu:26.10all versions · no fixed version listed
  • rpycUbuntu:26.04:LTSall versions · no fixed version listed
  • rpycUbuntu:25.10all versions · no fixed version listed
  • rpycUbuntu:24.04:LTSall versions · no fixed version listed
  • rpycUbuntu:22.04:LTSall versions · no fixed version listed

4 more package ranges on OSV.dev

Full record on NVD

Fix

  1. Update Rpyc project rpyc to 6.0.0

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2024-03-12
Last Modified
2026-06-17
NVD status
Deferred
GitHub Advisory
GHSA-h5cg-53g7-gqjw

Frequently asked questions

What is CVE-2024-27758?

In RPyC before 6.0.0, when a server exposes a method that calls the attribute named __array__ for a client-provided netref (e.g., np.array(client_netref)), a remote attacker can craft a class that results in remote code execution.

Is CVE-2024-27758 actively exploited?

A proof-of-concept exploit exists for CVE-2024-27758, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2024-27758?

CVE-2024-27758 has a CVSS v3 base score of 8.4 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running rpyc? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record