CVE-2023-6004
No exploitation reported by the sources we read.
- Published2024-01-03
- Fixed in0.10.6 · 0.9.8
- WeaknessCWE-74
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
A flaw was found in libssh. By utilizing the ProxyCommand or ProxyJump feature, users can exploit unchecked hostname syntax on the client. This issue may allow an attacker to inject malicious code into the command of the features mentioned through the hostname parameter.
Timeline
dates in UTC- 2024-01-0317:15CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-6004?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-6004?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 0.10 | ≥ 0.10.0, < 0.10.6 | 0.10.6 | NVD |
| 0.x | ≥ 0.8.0, < 0.9.8 | 0.9.8 | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 8.0 | = 8.0 | no fix published | NVD |
| 9.0 | = 9.0 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 38.x | = 38 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA3 products
As redhat, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Red Hat Enterprise Linux 8other versions: affected
package libsshhttps://access.redhat.com/downloads/content/package-browser/
Not affected ≥ 0:0.9.6-14.el8
- Red Hat Enterprise Linux 9other versions: affected
package libsshhttps://access.redhat.com/downloads/content/package-browser/
Not affected ≥ 0:0.10.4-13.el9
- Red Hat Enterprise Linux 7other versions: unknown
package libsshhttps://access.redhat.com/downloads/content/package-browser/
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-11-07
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- libsshWolfiall versions · fixed in 0.10.6-r0
- libsshUbuntu:Pro:18.04:LTSall versions · fixed in 0.8.0~20170825.94fa1e38-1ubuntu0.7+esm3
- libsshUbuntu:Pro:16.04:LTSall versions · fixed in 0.6.3-4.3ubuntu0.6+esm1
- libsshUbuntu:22.04:LTSall versions · fixed in 0.9.6-2ubuntu0.22.04.3
- libsshUbuntu:20.04:LTSall versions · fixed in 0.9.3-2ubuntu2.5
- libsshTuxCare:CentOS:8.5all versions · fixed in 0.9.4-3.el8.tuxcare.els3and 2 other packages
- libsshTuxCare:CentOS:8.4all versions · fixed in 0.9.4-3.el8.tuxcare.els3and 2 other packages
- libsshTuxCare:AlmaLinux:9.2all versions · fixed in 0.10.4-8.el9.tuxcare.els1and 2 other packages
59 more package ranges on OSV.dev
Fix
- Update Libssh to 0.10.6 · 0.9.8
Advisories and patches
- access.redhat.comVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionnone2024-01-10
- OpenCVESSVC decisionnone—
- CNACVSS 3.14.8known since 2026-10-23
- NVDCVSS 3.14.8read 2026-10-23
- CNAweakness (CWE)CWE-74known since 2026-10-23
- NVDweakness (CWE)CWE-74read 2026-10-23
- FIRST EPSSEPSS score0.4 %2026-11-03
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- AZL-34942same flawAzure Linux · MIT
- CGA-f2q7-9hc5-4rp7same flawChainguard · CC-BY-NC-ND-4.0
- CGA-mjpc-c9pw-3wwvsame flawChainguard · CC-BY-NC-ND-4.0
- EUVD-2023-58271same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-f35j-mfvw-p857same flawGitHub Advisory Database · CC-BY-4.0
- ALSA-2024:2504advisory covering several CVEsAlmaLinux · MIT
- ALSA-2024:3233advisory covering several CVEsAlmaLinux · MIT
- DSA-5591-1advisory covering several CVEsDebian · LicenseRef-unstated
- MGASA-2023-0357advisory covering several CVEsMageia · LicenseRef-unstated
- OESA-2024-1040advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2024-1041advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2024-1044advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2024-1045advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2024-1089advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2024-1123advisory covering several CVEsopenEuler · LicenseRef-unstated
- openSUSE-SU-2024:13638-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- RHSA-2024:2504advisory covering several CVEsRed Hat · CC-BY-4.0
- RHSA-2024:3233advisory covering several CVEsRed Hat · CC-BY-4.0
- RLSA-2024:2504advisory covering several CVEsRocky Linux · BSD-3-Clause
- RLSA-2024:3233advisory covering several CVEsRocky Linux · BSD-3-Clause
- SUSE-SU-2024:0140-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0525-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0539-1advisory covering several CVEsSUSE · LicenseRef-unstated
- USN-6592-1advisory covering several CVEsUbuntu
- USN-6592-2advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- Published
- 2024-01-03
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-f35j-mfvw-p857
Frequently asked questions
What is CVE-2023-6004?
Is CVE-2023-6004 actively exploited?
What is the CVSS score for CVE-2023-6004?
Running libssh? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
- CVE-2023-48795same product
- CVE-2021-3634same product
- CVE-2025-5318same productLibssh: out-of-bounds read in sftp_handle()
- CVE-2025-5987same product
- CVE-2023-6918same product
- CVE-2023-1667same product
- CVE-2023-2283same product
- CVE-2025-5449same productLibssh: integer overflow in libssh sftp server packet length validation leading to denial of service
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-f35j-mfvw-p857
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- CISA Vulnrichment · CC0-1.0