Skip to main content
No exploitation reportedFix available

CVE-2023-50269

No exploitation reported by the sources we read.

  • Published2023-12-14
  • WeaknessCWE-674

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Squid is a caching proxy for the Web. Due to an Uncontrolled Recursion bug in versions 2.6 through 2.7.STABLE9, versions 3.1 through 5.9, and versions 6.0.1 through 6.5, Squid may be vulnerable to a Denial of Service attack against HTTP Request parsing. This problem allows a remote client to perform Denial of Service attack by sending a large X-Forwarded-For header when the follow_x_forwarded_for feature is configured. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives.

Timeline

dates in UTC
  1. 2023-12-1418:15CVE publishedNVD
  2. 2026-10-2319:23EPSS crossed 10 %FIRST EPSS

Observed activity

isMalicious corpus · updated 2026-10-28 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-50269?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-50269?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Squid-cache squid
BranchAffectedFixed in
2.7= 2.7no fix published
5.9≥ 3.1, ≤ 5.9no fix published
6.x≥ 6.0.1, ≤ 6.5no fix published
2.6= 2.6no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libecapAlmaLinux:8all versions · fixed in 1.0.1-2.module_el8.6.0+2741+01592ae8and 1 other package
  • libecapAlmaLinux:8all versions · fixed in 1.0.1-2.module_el8.6.0+3048+383bc947and 1 other package
  • squidAlmaLinux:9all versions · fixed in 7:5.5-6.el9_3.8
  • squidAlmaLinux:8all versions · fixed in 7:4.15-7.module_el8.9.0+3749+dbf371ed.10

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub

Sources

  • CISA-ADPSSVC decisionnone2023-12-19
  • OpenCVESSVC decisionnone—
  • CNACVSS 3.18.6read 2026-10-23
  • NVDCVSS 3.17.5read 2026-10-23
  • CNAweakness (CWE)CWE-674read 2026-10-23
  • FIRST EPSSEPSS score57.6 %read 2026-10-28
  • OSVaffected packages—

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
2023-12-14
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2023-50269?

Squid is a caching proxy for the Web. Due to an Uncontrolled Recursion bug in versions 2.6 through 2.7.STABLE9, versions 3.1 through 5.9, and versions 6.0.1 through 6.5, Squid may be vulnerable to a Denial of Service attack against HTTP Request parsing. This problem allows a remote client to perform Denial of Service attack by sending a large X-Forwarded-For header when the follow_x_forwarded_for feature is configured. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives.

Is CVE-2023-50269 actively exploited?

Active exploitation of CVE-2023-50269 has not been confirmed. Its EPSS score was 57.6% on 2026-10-26, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-50269?

CVE-2023-50269 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running libecap? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month