CVE-2023-49938
No exploitation reported by the sources we read.
- Published2023-12-14
- Fixed in23.02.7 · 22.05.11
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
An issue was discovered in SchedMD Slurm 22.05.x and 23.02.x. There is Incorrect Access Control: an attacker can modified their extended group list that is used with the sbcast subsystem, and open files with an unauthorized set of extended groups. The fixed versions are 22.05.11 and 23.02.7.
Timeline
dates in UTC- 2023-12-1405:15CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 15:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-49938?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-49938?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 23.2 | ≥ 23.02.0, < 23.02.7 | 23.02.7 | NVD |
| 22.5 | ≥ 22.05.0, < 22.05.11 | 22.05.11 | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- slurmSUSE:Linux Enterprise Module for Package Hub 15 SP5all versions · fixed in 23.02.7-150500.5.15.1
- slurmSUSE:Linux Enterprise Module for Package Hub 15 SP5all versions · fixed in 20.11.9-150400.3.3.1
- slurmSUSE:Linux Enterprise Module for HPC 15 SP5all versions · fixed in 23.02.7-150500.5.15.1
- slurmSUSE:Linux Enterprise Module for HPC 12all versions · fixed in 17.02.11-6.59.1
- slurmSUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSall versions · fixed in 20.11.9-150400.3.3.1
- slurmSUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSall versions · fixed in 20.11.9-150400.3.3.1
- slurmSUSE:Linux Enterprise High Performance Computing 15 SP3-LTSSall versions · fixed in 20.11.9-150300.4.12.1
- slurmSUSE:Linux Enterprise High Performance Computing 15 SP2-LTSSall versions · fixed in 20.02.7-150200.3.20.1
27 more package ranges on OSV.dev
Fix
- Update Schedmd slurm to 23.02.7 · 22.05.11
Advisories and patches
- lists.schedmd.comVendor Advisory
- www.schedmd.comVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.18.2read 2026-10-23
- FIRST EPSSEPSS score0.7 %2026-11-03
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2023-53833same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-3j4p-qc5m-wqghsame flawGitHub Advisory Database · CC-BY-4.0
- DSA-5609-1advisory covering several CVEsDebian · LicenseRef-unstated
- SUSE-SU-2024:0278-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0279-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0280-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0283-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0284-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0286-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0287-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0288-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0289-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0309-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0310-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0311-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0312-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0313-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0314-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2024:0315-1advisory covering several CVEsSUSE · LicenseRef-unstated
- USN-8236-1advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- Published
- 2023-12-14
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-3j4p-qc5m-wqgh
Frequently asked questions
What is CVE-2023-49938?
Is CVE-2023-49938 actively exploited?
What is the CVSS score for CVE-2023-49938?
Running slurm? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-3j4p-qc5m-wqgh
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served