CVE-2023-43654
Exploitation reported by one source. First attested on 2025-11-26 by GCVE · shadowserver.
- Published2023-09-28
- Fixed in0.8.2
- WeaknessCWE-918
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
TorchServe is a tool for serving and scaling PyTorch models in production. TorchServe default configuration lacks proper input validation, enabling third parties to invoke remote HTTP download requests and write files to the disk. This issue could be taken advantage of to compromise the integrity of the system and sensitive data. This issue is present in versions 0.1.0 to 0.8.1. A user is able to load the model of their choice from any URL that they would like to use. The user of TorchServe is responsible for configuring both the allowed_urls and specifying the model URL to be used. A pull request to warn the user when the default value for allowed_urls is used has been merged in PR #2534. TorchServe release 0.8.2 includes this change. Users are advised to upgrade. There are no known workarounds for this issue.
Timeline
dates in UTC- 2023-09-2823:15CVE publishedNVD
- 2025-11-2603:32Listed as exploited by GCVEGCVE
- 2025-11-2603:32Exploitation first reportedGCVE
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-43654?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-43654?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD · CISA-ADP · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 0.x | ≥ 0.1.0, < 0.8.2 | 0.8.2 | NVD · CISA-ADP · OSV |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- pytorch serveAffected
- = >= 0.1.0, < 0.8.2no fix stated
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-09-28
Fix
- Update Pytorch torchserve to 0.8.2
Advisories and patches
- github.comRelease Notes
- github.comVendor Advisory
Detection
read 2026-11-02 22:42 UTC- Nuclei template
- available ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- 2 repositories, unverifiedOligoCyberSecurity/ShellTorchCheckerOligoCyberSecurity/CVE-2023-43654 PoC-in-GitHub
- Metasploit modules
- 1 moduleexploit/multi/http/torchserver_cve_2023_43654rank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
Sources
- GCVEexploitation2025-11-26
- CISA-ADPSSVC decisionpoc2024-09-23
- OpenCVESSVC decisionpoc—
- CNACVSS 3.110known since 2026-10-23
- NVDCVSS 3.19.8read 2026-10-23
- CNAweakness (CWE)CWE-918known since 2026-10-23
- FIRST EPSSEPSS score42.5 %read 2026-11-02
- PoC-in-GitHubproof of concept2read 2026-11-02
- ProjectDiscoverydetectionread 2026-11-02
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- OSVaffected packages—
- GitHub AdvisoriesadvisoryCRITICAL2023-10-02
Identifiers
- EUVD-2023-2697same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-8fxr-qfr9-p34wsame flawGitHub Advisory Database · CC-BY-4.0
- PYSEC-2026-553same flawPyPA Advisory Database · CC-BY-4.0
- exploit/multi/http/torchserver_cve_2023_43654exploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2023-09-28
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-8fxr-qfr9-p34w
Frequently asked questions
What is CVE-2023-43654?
Is CVE-2023-43654 actively exploited?
What is the CVSS score for CVE-2023-43654?
Running torchserve? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- For a threat intelligence platform: malware, C2 and ransomware indicators over STIX/TAXII.
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GCVE · GCVE dump terms (preserve source attribution)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-8fxr-qfr9-p34w
- Metasploit Framework · BSD-3-Clause
- Nuclei templates · MIT
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- PoC-in-GitHub · CC0-1.0
- CISA Vulnrichment · CC0-1.0