Skip to main content
Public proof of conceptFix available

CVE-2023-43651

A public proof of concept exists; no exploitation attested.

  • Published2023-09-27
  • Fixed in3.7.1 · 2.28.20
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

JumpServer is an open source bastion host. An authenticated user can exploit a vulnerability in MongoDB sessions to execute arbitrary commands, leading to remote code execution. This vulnerability may further be leveraged to gain root privileges on the system. Through the WEB CLI interface provided by the koko component, a user logs into the authorized mongoDB database and exploits the MongoDB session to execute arbitrary commands. This vulnerability has been addressed in versions 2.28.20 and 3.7.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Timeline

dates in UTC
  1. 2023-09-2721:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-43651?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-43651?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV · CISA-ADP
Fit2cloud jumpserver
BranchAffectedFixed in
3.x≥ 3.0.0, < 3.7.13.7.1
2.x≥ 2.0.0, < 2.28.202.28.20
Jumpserver
BranchAffectedFixed in
3.x≥ 3.0.0, < 3.7.13.7.1
2.x≥ 2.0.0, < 2.28.202.28.20

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • jumpserver
    Affected
    • = >= 2.0.0, < 2.28.20no fix stated
    • = >= 3.0.0, < 3.7.1no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2025-03-25

Fix

  1. Update Fit2cloud jumpserver to 3.7.1 · 2.28.20

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionpoc2024-09-23
  • OpenCVESSVC decisionpoc—
  • CNACVSS 3.18.5known since 2026-10-23
  • NVDCVSS 3.19.9read 2026-10-23
  • CNAweakness (CWE)CWE-94known since 2026-10-23
  • NVDweakness (CWE)CWE-94read 2026-10-23
  • FIRST EPSSEPSS score2.1 %2026-11-03
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryMODERATE2023-10-24

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Published
2023-09-27
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-4r5x-x283-wm96

Frequently asked questions

What is CVE-2023-43651?

JumpServer is an open source bastion host. An authenticated user can exploit a vulnerability in MongoDB sessions to execute arbitrary commands, leading to remote code execution. This vulnerability may further be leveraged to gain root privileges on the system. Through the WEB CLI interface provided by the koko component, a user logs into the authorized mongoDB database and exploits the MongoDB session to execute arbitrary commands. This vulnerability has been addressed in versions 2.28.20 and 3.7.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Is CVE-2023-43651 actively exploited?

A proof-of-concept exploit exists for CVE-2023-43651, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2023-43651?

CVE-2023-43651 has a CVSS v3 base score of 9.9 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H.

Running jumpserver/koko? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record