CVE-2023-42114
No exploitation reported by the sources we read.
- Published2024-05-03
- Fixed in4.97 · 4.96.1
- WeaknessCWE-125
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Exim NTLM Challenge Out-Of-Bounds Read Information Disclosure Vulnerability. This vulnerability allows remote attackers to disclose sensitive information on affected installations of Exim. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of NTLM challenge requests. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated data structure. An attacker can leverage this vulnerability to disclose information in the context of the service account. . Was ZDI-CAN-17433.
Timeline
dates in UTC- 2024-05-0303:15CVE publishedNVD
- 2026-10-2319:23EPSS crossed 10 %FIRST EPSS
Observed activity
isMalicious corpus · updated 2026-11-04 15:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-42114?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-42114?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
CISA-ADP · NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 4.97 | < 4.97 | 4.97 | CISA-ADP |
| 4.96 | < 4.96.1 | 4.96.1 | NVD · CISA-ADP |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As zdi, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Eximother versions: unknownAffected
- = exim 4.95no fix stated
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2024-09-18
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- eximWolfiall versions · fixed in 4.96.1-r0
- eximTuxCare:OracleLinux:6all versions · fixed in 4.92.3-3.el6.tuxcare.els4and 4 other packages
- eximTuxCare:CentOS:6all versions · fixed in 4.92.3-3.el6.tuxcare.els4and 4 other packages
- eximSUSE:Package Hub 15 SP5all versions · fixed in 4.94.2-bp155.5.3.1
- eximSUSE:Package Hub 15 SP5all versions · fixed in 4.97.1-bp155.5.9.1
- eximSUSE:Package Hub 15 SP4all versions · fixed in 4.94.2-bp155.5.3.1
- eximopenSUSE:Tumbleweedall versions · fixed in 4.96.1-1.1
- eximopenSUSE:Leap 15.5all versions · fixed in 4.94.2-bp155.5.3.1
24 more package ranges on OSV.dev
Fix
- Update Exim to 4.97 · 4.96.1
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionnone2024-05-03
- OpenCVESSVC decisionnone—
- NVDCVSS 3.15.3read 2026-10-23
- CNACVSS 3.03.7known since 2026-10-23
- CNAweakness (CWE)CWE-125known since 2026-10-23
- FIRST EPSSEPSS score27.1 %read 2026-11-03
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- CGA-39vr-qmjg-x794same flawChainguard · CC-BY-NC-ND-4.0
- CGA-5w83-q2j4-4gxqsame flawChainguard · CC-BY-NC-ND-4.0
- EUVD-2023-46573same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-h5j4-2q8w-q3q4same flawGitHub Advisory Database · CC-BY-4.0
- DLA-3599-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-5512-1advisory covering several CVEsDebian · LicenseRef-unstated
- openSUSE-SU-2023:0293-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2024:0007-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2024:13282-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- USN-6411-1advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Published
- 2024-05-03
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-h5j4-2q8w-q3q4
Frequently asked questions
What is CVE-2023-42114?
Is CVE-2023-42114 actively exploited?
What is the CVSS score for CVE-2023-42114?
Running exim4? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-h5j4-2q8w-q3q4
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- CISA Vulnrichment · CC0-1.0