Skip to main content
No exploitation reportedFix available

CVE-2023-41914

No exploitation reported by the sources we read.

  • Published2023-11-03
  • Fixed in23.02.6 · 22.05.10
  • WeaknessCWE-362

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

SchedMD Slurm 23.02.x before 23.02.6 and 22.05.x before 22.05.10 allows filesystem race conditions for gaining ownership of a file, overwriting a file, or deleting files.

Timeline

dates in UTC
  1. 2023-11-0305:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-41914?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-41914?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · CISA-ADP
Schedmd slurm
BranchAffectedFixed in
23.2≥ 23.02, < 23.02.623.02.6
23.2≥ 23.02x, < 23.02.623.02.6
22.5≥ 22.05, < 22.05.1022.05.10
22.5≥ 22.05x, < 22.05.1022.05.10
Fedoraproject fedora
BranchAffectedFixed in
39.x= 39no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • slurmSUSE:Linux Enterprise Module for Package Hub 15 SP5all versions · fixed in 23.02.6-150500.5.12.1
  • slurmSUSE:Linux Enterprise Module for Package Hub 15 SP5all versions · fixed in 20.11.9-150400.3.3.1
  • slurmSUSE:Linux Enterprise Module for HPC 15 SP5all versions · fixed in 23.02.6-150500.5.12.1
  • slurmSUSE:Linux Enterprise Module for HPC 12all versions · fixed in 17.02.11-6.56.1
  • slurmSUSE:Linux Enterprise High Performance Computing 15 SP4-LTSSall versions · fixed in 20.11.9-150400.3.3.1
  • slurmSUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOSall versions · fixed in 20.11.9-150400.3.3.1
  • slurmSUSE:Linux Enterprise High Performance Computing 15 SP3-LTSSall versions · fixed in 20.11.9-150300.4.9.1
  • slurmSUSE:Linux Enterprise High Performance Computing 15 SP3-LTSSall versions · fixed in 20.11.9-150300.4.12.1

40 more package ranges on OSV.dev

Full record on NVD

Fix

  1. Update Schedmd slurm to 23.02.6 · 22.05.10

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2023-11-03
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-v8jm-8mp9-5962

Frequently asked questions

What is CVE-2023-41914?

SchedMD Slurm 23.02.x before 23.02.6 and 22.05.x before 22.05.10 allows filesystem race conditions for gaining ownership of a file, overwriting a file, or deleting files.

Is CVE-2023-41914 actively exploited?

Active exploitation of CVE-2023-41914 has not been confirmed. Its EPSS score was 0.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-41914?

CVE-2023-41914 has a CVSS v3 base score of 7 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running slurm? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record