Skip to main content
No exploitation reportedFix available

CVE-2023-41038

No exploitation reported by the sources we read.

  • Published2024-03-20
  • Fixed in5.0.0.1176 · 4.0.4.2981
  • WeaknessCWE-770

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Firebird is a relational database. Versions 4.0.0 through 4.0.3 and version 5.0 beta1 are vulnerable to a server crash when a user uses a specific form of SET BIND statement. Any non-privileged user with minimum access to a server may type a statement with a long `CHAR` length, which causes the server to crash due to stack corruption. Versions 4.0.4.2981 and 5.0.0.117 contain fixes for this issue. No known workarounds are available.

Timeline

dates in UTC
  1. 2024-03-2015:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-41038?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-41038?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

CISA-ADP · NVD
Firebirdsql firebird
BranchAffectedFixed in
5.0≥ 5.0_beta1, < 5.0.0.11765.0.0.1176
4.0≥ 4.0.0, < 4.0.4.29814.0.4.2981
4.0≥ 4.0.0, ≤ 4.0.3no fix published
5.0= 5.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • FirebirdSQL firebird
    Affected
    • = >= 4.0.0, < 4.0.4.2981no fix stated
    • = >= 5.0 beta1, < 5.0.0.1176no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2024-03-20

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • firebird2.5Ubuntu:Pro:16.04:LTSall versions · no fixed version listed
  • firebird2.5Ubuntu:14.04:LTSall versions · no fixed version listed
  • relationalUbuntu:26.10all versions · no fixed version listedand 1 other package
  • relationalUbuntu:26.04:LTSall versions · no fixed version listedand 1 other package
  • relationalUbuntu:25.10all versions · no fixed version listedand 1 other package
  • relationalUbuntu:24.04:LTSall versions · no fixed version listedand 1 other package
  • relationalUbuntu:22.04:LTSall versions · no fixed version listedand 1 other package
  • relationalUbuntu:20.04:LTSall versions · no fixed version listedand 1 other package

2 more package ranges on OSV.dev

Full record on NVD

Fix

  1. Update Firebirdsql firebird to 5.0.0.1176 · 4.0.4.2981

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVE recordread 2026-10-23
  • CISA-ADPSSVC decisionnone2024-03-20
  • OpenCVESSVC decisionnone—
  • CNACVSS 3.17.5known since 2026-10-23
  • CNAweakness (CWE)CWE-770known since 2026-10-23
  • FIRST EPSSEPSS score0.7 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
2024-03-20
Last Modified
2026-06-17
NVD status
Analyzed

Frequently asked questions

What is CVE-2023-41038?

Firebird is a relational database. Versions 4.0.0 through 4.0.3 and version 5.0 beta1 are vulnerable to a server crash when a user uses a specific form of SET BIND statement. Any non-privileged user with minimum access to a server may type a statement with a long `CHAR` length, which causes the server to crash due to stack corruption. Versions 4.0.4.2981 and 5.0.0.117 contain fixes for this issue. No known workarounds are available.

Is CVE-2023-41038 actively exploited?

Active exploitation of CVE-2023-41038 has not been confirmed. Its EPSS score was 0.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-41038?

CVE-2023-41038 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running relational? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record