Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2023-38646

Exploitation confirmed. First attested on 2023-10-13 by GCVE · kevintel, GCVE · shadowserver.

  • Published2023-07-21
  • Fixed in1.46.6.1 · 1.45.4.1 · 1.44.7.1 · 1.43.7.2 · 0.46.6.1 · 0.45.4.1

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow attackers to execute arbitrary commands on the server, at the server's privilege level. Authentication is not required for exploitation. The other fixed versions are 0.45.4.1, 1.45.4.1, 0.44.7.1, 1.44.7.1, 0.43.7.2, and 1.43.7.2.

Timeline

dates in UTC
  1. 2023-07-2115:15CVE publishedNVD
  2. 2023-10-1316:00Listed as exploited by GCVEGCVE
  3. 2023-10-1316:00Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-38646?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-38646?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Metabase
BranchAffectedFixed in
1.46≥ 1.46.0, < 1.46.6.11.46.6.1
1.45≥ 1.45.0, < 1.45.4.11.45.4.1
1.44≥ 1.44.0, < 1.44.7.11.44.7.1
1.43< 1.43.7.21.43.7.2
0.46≥ 0.46.0, < 0.46.6.10.46.6.1
0.45≥ 0.45.0, < 0.45.4.10.45.4.1
0.44≥ 0.44.0, < 0.44.7.10.44.7.1
0.43< 0.43.7.20.43.7.2

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • metabase-compatChainguardall versions · fixed in 0and 1 other package

Full record on NVD

Fix

  1. Update Metabase to 1.46.6.1 · 1.45.4.1 · 1.44.7.1 · 1.43.7.2 · 0.46.6.1 · 0.45.4.1 · 0.44.7.1 · 0.43.7.2

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleexploit/linux/http/metabase_setup_token_rcerank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-07-21
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2023-38646?

Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow attackers to execute arbitrary commands on the server, at the server's privilege level. Authentication is not required for exploitation. The other fixed versions are 0.45.4.1, 1.45.4.1, 0.44.7.1, 1.44.7.1, 0.43.7.2, and 1.43.7.2.

Is CVE-2023-38646 actively exploited?

Active exploitation of CVE-2023-38646 has not been confirmed. Its EPSS score was 99.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-38646?

CVE-2023-38646 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running metabase-compat? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record