CVE-2023-36478
No exploitation reported by the sources we read.
- Published2023-10-10
- WeaknessCWE-190 · CWE-400
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Eclipse Jetty provides a web server and servlet container. In versions 11.0.0 through 11.0.15, 10.0.0 through 10.0.15, and 9.0.0 through 9.4.52, an integer overflow in `MetaDataBuilder.checkSize` allows for HTTP/2 HPACK header values to exceed their size limit. `MetaDataBuilder.java` determines if a header name or value exceeds the size limit, and throws an exception if the limit is exceeded. However, when length is very large and huffman is true, the multiplication by 4 in line 295 will overflow, and length will become negative. `(_size+length)` will now be negative, and the check on line 296 will not be triggered. Furthermore, `MetaDataBuilder.checkSize` allows for user-entered HPACK header value sizes to be negative, potentially leading to a very large buffer allocation later on when the user-entered size is multiplied by 2. This means that if a user provides a negative length value (or, more precisely, a length value which, when multiplied by the 4/3 fudge factor, is negative), and this length value is a very large positive number when multiplied by 2, then the user can cause a very large buffer to be allocated on the server. Users of HTTP/2 can be impacted by a remote denial of service attack. The issue has been fixed in versions 11.0.16, 10.0.16, and 9.4.53. There are no known workarounds.
Timeline
dates in UTC- 2023-10-1017:15CVE publishedNVD
Versions per branch
NVD · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 12.0 | = 12.0 | no fix published | NVD |
| 10.0 | = 10.0 | no fix published | NVD |
| 11.0 | = 11.0 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 11.0 | ≥ 11.0.0, < 11.0.16 | 11.0.16 | NVD · OSV |
| 10.0 | ≥ 10.0.0, < 10.0.16 | 10.0.16 | NVD · OSV |
| 9.x | ≥ 9.3.0, < 9.4.53 | 9.4.53 | NVD · OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 2.428 | < 2.428 | 2.428 | NVD |
| 2.414 | < 2.414.3 | 2.414.3 | NVD |
1 more product in the sources.
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- jettyUbuntu:16.04:LTSall versions · no fixed version listed
- jettyUbuntu:14.04:LTSall versions · no fixed version listed
- jetty-minimalSUSE:Linux Enterprise Server for SAP Applications 15 SP3all versions · fixed in 9.4.53-150200.3.22.1
- jetty-minimalSUSE:Linux Enterprise Server for SAP Applications 15 SP2all versions · fixed in 9.4.53-150200.3.22.1
- jetty-minimalSUSE:Linux Enterprise Server 15 SP3-LTSSall versions · fixed in 9.4.53-150200.3.22.1
- jetty-minimalSUSE:Linux Enterprise Server 15 SP2-LTSSall versions · fixed in 9.4.53-150200.3.22.1
- jetty-minimalSUSE:Linux Enterprise Module for Development Tools 15 SP5all versions · fixed in 9.4.53-150200.3.22.1
- jetty-minimalSUSE:Linux Enterprise Module for Development Tools 15 SP4all versions · fixed in 9.4.53-150200.3.22.1
20 more package ranges on OSV.dev
Vendor advisories
jetty: hpack header values cause denial of service in http/2
jenkins.src as a component of OpenShift Developer Tools and Services · http2-hpack as a component of Red Hat Integration Camel Quarkus 2 · jetty as a component of Red Hat JBoss Fuse 6 · +8 more
Red Hat Security Advisory: Red Hat Fuse 7.13.0 release and security update
Red Hat Security Advisory: Red Hat Fuse 7.12.1 release and security update
Fix
- Vendor fix Red Hat Product Security RHSA-2024:3354 · 1 productBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://access.redhat.com/articles/11258
- Vendor fix Red Hat Product Security RHSA-2023:7247 · 1 productBefore applying the update, back up your existing installation, including all applications, configuration files, databases and database settings, and so on. The References section of this erratum contains a download link (you must log in to download the update).
- Workaround from the vendor Red Hat Product Security RHSA-2024:3354 · 1 productNo mitigations are currently available for this vulnerability.
- No fix available, says the vendor Red Hat Product Security CVE-2023-36478 · 5 productsAffected
- No fix planned, says the vendor Red Hat Product Security CVE-2023-36478 · 5 productsOut of support scope
- No fix planned, says the vendor Red Hat Product Security CVE-2023-36478 · 1 productWill not fix
Advisories and patches
- github.comPatch
- github.comRelease Notes
- github.comRelease Notes
- github.comRelease Notes
- github.comVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof of concept
- PoC-in-GitHubno public repository identifiedread 2026-11-07
- Metasploit modules
- none listed Metasploit Framework
Sources
- CNACVSS 3.17.5known since 2026-10-23
- NVDCVSS 3.17.5read 2026-10-23
- CNAweakness (CWE)CWE-190, CWE-400known since 2026-10-23
- NVDweakness (CWE)CWE-190read 2026-10-23
- FIRST EPSSEPSS score4.8 %2026-11-06
- OSVaffected packages—
- GitHub AdvisoriesadvisoryHIGH2023-10-10
Identifiers
- BIT-jenkins-2023-36478same flawBitnami · Apache-2.0
- EUVD-2023-2828same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-wgh7-54f2-x98rsame flawGitHub Advisory Database · CC-BY-4.0
- DLA-3641-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-5540-1advisory covering several CVEsDebian · LicenseRef-unstated
- SUSE-SU-2023:4210-1advisory covering several CVEsSUSE · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Published
- 2023-10-10
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-wgh7-54f2-x98r
Frequently asked questions
What is CVE-2023-36478?
Is CVE-2023-36478 actively exploited?
What is the CVSS score for CVE-2023-36478?
Running jetty? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-wgh7-54f2-x98r
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0