CVE-2019-10241
No exploitation reported by the sources we read.
- Published2019-04-22
- WeaknessCWE-79
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
In Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote client USES a specially formatted URL against the DefaultServlet or ResourceHandler that is configured for showing a Listing of directory contents.
Timeline
dates in UTC- 2019-04-2220:29CVE publishedNVD
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 9.2 | = 9.2.0 | no fix published | NVD |
| 9.2 | = 9.2.1 | no fix published | NVD |
| 9.2 | = 9.2.2 | no fix published | NVD |
| 9.2 | = 9.2.3 | no fix published | NVD |
| 9.2 | = 9.2.4 | no fix published | NVD |
| 9.2 | = 9.2.5 | no fix published | NVD |
| 9.2 | = 9.2.6 | no fix published | NVD |
| 9.2 | = 9.2.7 | no fix published | NVD |
| 9.2 | = 9.2.8 | no fix published | NVD |
| 9.2 | = 9.2.9 | no fix published | NVD |
| 9.2 | = 9.2.10 | no fix published | NVD |
| 9.2 | = 9.2.11 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 11.2 | = 11.2.0.4 | no fix published | NVD |
| 12.1 | = 12.1.0.2 | no fix published | NVD |
| 12.2 | = 12.2.0.1 | no fix published | NVD |
| 18.x | = 18c | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 7.1 | = 7.1 | no fix published | NVD |
| 15.0 | = 15.0 | no fix published | NVD |
| 16.0 | = 16.0 | no fix published | NVD |
| 17.0 | = 17.0 | no fix published | NVD |
5 more products in the sources.
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- apache-hiveCleanStartall versions · fixed in 3.1.3-r3
- hadoop-fips-3.5Chainguardall versions · no fixed version listedand 2 other packages
- jettyUbuntu:16.04:LTSall versions · no fixed version listedand 1 other package
- jettyUbuntu:14.04:LTSall versions · no fixed version listedand 1 other package
- jettyopenEuler:22.03-LTSall versions · fixed in 9.4.16-1.oe2203
- jettyopenEuler:20.03-LTS-SP3all versions · fixed in 9.4.16-1.oe1
- jettyopenEuler:20.03-LTS-SP1all versions · fixed in 9.4.16-1.oe1
- jetty9Ubuntu:18.04:LTSall versions · no fixed version listed
6 more package ranges on OSV.dev
Vendor advisories
Red Hat Security Advisory: Red Hat AMQ Broker 7.4.3 release and security update
Red Hat Security Advisory: Red Hat Fuse 7.6.0 security update
Red Hat Security Advisory: Red Hat AMQ Broker 7.6 release and security update
Fix
- Vendor fix Red Hat Product Security RHSA-2020:1445 · 1 productBefore applying the update, back up your existing installation, including all applications, configuration files, databases and database settings, and so on. The References section of this erratum contains a download link (you must log in to download the update).
- Vendor fix Red Hat Product Security RHSA-2020:0983 · 1 productBefore applying the update, back up your existing installation, including all applications, configuration files, databases and database settings, and so on. Installation instructions are available from the Fuse 7.6.0 product documentation page: https://access.redhat.com/documentation/en-us/red_hat…
Advisories and patches
- bugs.eclipse.orgVendor Advisory
- www.oracle.comPatch
- www.oracle.comPatch
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof of concept
- PoC-in-GitHubno public repository identifiedread 2026-11-07
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.16.1read 2026-10-23
- NVDCVSS 2.04.3read 2026-10-23
- CNAweakness (CWE)CWE-79known since 2026-10-23
- NVDweakness (CWE)CWE-79read 2026-10-23
- FIRST EPSSEPSS score9.4 %2026-11-06
- OSVaffected packages—
- GitHub AdvisoriesadvisoryMODERATE2019-04-23
Identifiers
- CGA-2447-739m-9hjvsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-2g77-qph3-562msame flawChainguard · CC-BY-NC-ND-4.0
- CGA-45p5-x24p-47hpsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-4c2r-m5qc-5hg5same flawChainguard · CC-BY-NC-ND-4.0
- CGA-5v7x-jjrv-m4j8same flawChainguard · CC-BY-NC-ND-4.0
- CGA-7mr5-xc8m-3594same flawChainguard · CC-BY-NC-ND-4.0
- CGA-9h52-jqp2-5j42same flawChainguard · CC-BY-NC-ND-4.0
- CGA-cc2x-cvvm-xwmfsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-m693-3fch-qgxgsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-rf52-88hv-r28wsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-rq2m-96f9-4v25same flawChainguard · CC-BY-NC-ND-4.0
- CGA-vhm9-7486-4h2xsame flawChainguard · CC-BY-NC-ND-4.0
- CGA-vmwv-8vpf-pwh2same flawChainguard · CC-BY-NC-ND-4.0
- CGA-x48v-rmhr-vhp4same flawChainguard · CC-BY-NC-ND-4.0
- EUVD-2019-0408same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-7vx9-xjhr-rw6hsame flawGitHub Advisory Database · CC-BY-4.0
- DLA-2661-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-4949-1advisory covering several CVEsDebian · LicenseRef-unstated
- OESA-2022-2140advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2022-2148advisory covering several CVEsopenEuler · LicenseRef-unstated
- OESA-2022-2149advisory covering several CVEsopenEuler · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Published
- 2019-04-22
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-7vx9-xjhr-rw6h
Frequently asked questions
What is CVE-2019-10241?
Is CVE-2019-10241 actively exploited?
What is the CVSS score for CVE-2019-10241?
Running Red Hat Fuse 7.6.0? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-7vx9-xjhr-rw6h
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0