Skip to main content
Public proof of conceptFix available

CVE-2023-3124

A public proof of concept exists; no exploitation attested.

  • Published2023-06-07
  • Fixed in3.11.7
  • WeaknessCWE-862

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Elementor Pro plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the update_page_option function in versions up to, and including, 3.11.6. This makes it possible for authenticated attackers with subscriber-level capabilities to update arbitrary site options, which can lead to privilege escalation.

Timeline

dates in UTC
  1. 2023-06-0702:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-3124?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-3124?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Elementor elementor pro
BranchAffectedFixed in
3.11< 3.11.73.11.7

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As Wordfence, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • https://elementor.com/ Elementor Website Builder Proother versions: not affected
    Affected
    • ≤ 3.11.6no fix statedsemver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-04-08

Fix

  1. Update Elementor elementor pro to 3.11.7

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedAmirWhiteHat/CVE-2023-3124
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2023-06-07
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-7j8c-j5qm-w6xf

Frequently asked questions

What is CVE-2023-3124?

The Elementor Pro plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the update_page_option function in versions up to, and including, 3.11.6. This makes it possible for authenticated attackers with subscriber-level capabilities to update arbitrary site options, which can lead to privilege escalation.

Is CVE-2023-3124 actively exploited?

Active exploitation of CVE-2023-3124 has not been confirmed. Its EPSS score was 22.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-3124?

CVE-2023-3124 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record