Skip to main content
Exploitation reportedNot in CISA KEV yetFix available

CVE-2023-28121

Exploitation reported by one source. First attested on 2023-07-17 by GCVE · kevintel.

  • Published2023-04-12
  • Fixed in5.5.2 · 5.2.2 · 5.1.3 · 5.0.4 · 4.8.2
  • WeaknessCWE-287

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated.

Timeline

dates in UTC
  1. 2023-04-1221:15CVE publishedNVD
  2. 2023-07-1710:27Listed as exploited by GCVEGCVE
  3. 2023-07-1710:27Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-28121?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-28121?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Automattic woocommerce payments
BranchAffectedFixed in
5.5≥ 5.5.0, < 5.5.25.5.2
5.2≥ 5.2.0, < 5.2.25.2.2
5.1≥ 5.1.0, < 5.1.35.1.3
5.0≥ 5.0.0, < 5.0.45.0.4
4.8≥ 4.8.0, < 4.8.24.8.2
Automattic woopayments
BranchAffectedFixed in
5.6≥ 5.6.0, < 5.6.25.6.2
4.9= 4.9.0no fix published
5.3= 5.3.0no fix published
5.4= 5.4.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Automattic woocommerce payments to 5.5.2 · 5.2.2 · 5.1.3 · 5.0.4 · 4.8.2

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
1 moduleauxiliary/scanner/http/wp_woocommerce_payments_add_userrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-04-12
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2023-28121?

An issue in WooCommerce Payments plugin for WordPress (versions 5.6.1 and lower) allows an unauthenticated attacker to send requests on behalf of an elevated user, like administrator. This allows a remote, unauthenticated attacker to gain admin access on a site that has the affected version of the plugin activated.

Is CVE-2023-28121 actively exploited?

Active exploitation of CVE-2023-28121 has not been confirmed. Its EPSS score was 87.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2023-28121?

CVE-2023-28121 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record