Skip to main content
ExploitedIn CISA KEVFix available

CVE-2023-27524

Exploitation confirmed. First attested on 2024-01-08 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2023-04-24
  • Fixed in2.0.2
  • WeaknessCWE-1188

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config. All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database. Add a strong SECRET_KEY to your `superset_config.py` file like: SECRET_KEY = <YOUR_OWN_RANDOM_GENERATED_SECRET_KEY> Alternatively you can set it with `SUPERSET_SECRET_KEY` environment variable.

Timeline

dates in UTC
  1. 2023-04-2416:15CVE publishedNVD
  2. 2023-05-23Exploit-DB entryExploit-DB
  3. 2024-01-08Added to the CISA KEV catalogCISA KEV
  4. 2024-01-08Listed as exploited by GCVEGCVE
  5. 2024-01-08Exploitation first reportedCISA KEV
  6. 2025-02-0316:30SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-27524?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-27524?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
superset
BranchAffectedFixed in
2.0< 2.0.22.0.2
Apache superset
BranchAffectedFixed in
2.0≤ 2.0.1no fix published
apache-superset
BranchAffectedFixed in
2.1< 2.1.02.1.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As apache, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Apache Software Foundation Apache Supersetother versions: not affected
    Affected
    • ≤ 2.0.1no fix statedsemver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2024-04-08

Fix

  1. Update superset to 2.0.2
  2. CISA’s required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.due 2024-01-29

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-51447
Exploit-DB
Metasploit modules
2 modulesexploit/linux/http/apache_superset_cookie_sig_rcerank: goodauxiliary/gather/apache_superset_cookie_sig_priv_escrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2024-01-08
Patch Due Date
2024-01-29
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-04-24
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-5cx2-vq3h-x52c

Frequently asked questions

What is CVE-2023-27524?

Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config. All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database. Add a strong SECRET_KEY to your `superset_config.py` file like: SECRET_KEY = <YOUR_OWN_RANDOM_GENERATED_SECRET_KEY> Alternatively you can set it with `SUPERSET_SECRET_KEY` environment variable.

Is CVE-2023-27524 actively exploited?

Yes. CVE-2023-27524 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2024-01-29.

What is the CVSS score for CVE-2023-27524?

CVE-2023-27524 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running superset? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record